FormBuilder Drag-N-Drop is Not Working

  • Profile Image
    thaisxs
    Asked on July 21, 2013 at 12:27 PM

    Hi i'm trying to edit the field of the form but it doesn't have the edit button on the right for me to edit. The edit button only shows up when i drag a new textbox or field..

    How do it edit the previous field ?

  • Profile Image
    EliezerN
    Answered on July 21, 2013 at 12:42 PM

    Thanks for contacting us.

    If you want to edit a field you can find the tools to do it in the top menu when you click over the field. 

    If you want to edit the label text of a field, just click over the "Click to edit".

     

    We would appreciate if you told us how you'd like to edit the field and in that way we can assist you better.

    Thanks.

  • Profile Image
    thaisxs
    Answered on July 22, 2013 at 06:43 AM

    Hi EliezerN 

    Thank you for your assistance. 

     

    The problem i'm having is taking example from the attached picture i would like to move / edit the address field but i'm unable to do show because thats no property option show up on the right corner? Is this the limitation of the form or I'm doing it wrongly 

  • Profile Image
    sidharth_kch
    Answered on July 22, 2013 at 08:47 AM

    @thaisxs

    Address field is actually a collection/group of form fields.

    Editing individual fields or to reposition them will not be possible. Do you want to edit the label of the address fields?  You can do so by clicking the sub level of the individual field.

    Please let us know what exactly you want to change as there can be a possibility to achieve that by injecting custome css code in your form.

    Thanks,

    Sidharth

  • Profile Image
    thaisxs
    Answered on July 23, 2013 at 05:07 AM

    Hi sidharth_kch 

    what i'm trying to do is not to reposition the individual address field. What i'm trying to do is to move the entire address up . for eg to have the address above of Full Name field.

     

    Thanks 

  • Profile Image
    gori-mathew
    Answered on July 23, 2013 at 05:30 AM

    Hi,

    To move it up you just need to click on the field name and hold and then move it to the position that you wish to place it as shown below.

    Thanks!

  • Profile Image
    thaisxs
    Answered on July 23, 2013 at 06:02 AM

    Hi i tried to do what you have suggested but im not getting it :( 

    what did i miss out

     

  • Profile Image
    khrisell
    Answered on July 23, 2013 at 06:11 AM

    Hello,

    I have cloned the form and was able to drag the dropdown field on top of the Address field.

    Kindly check the form I cloned from yours

    here: http://form.jotformpro.com/form/32032242402940

     

    Just Drag the field to where you wanted to place it.

    I have tested also on your end. So it should work.

    Let us know if problem persists so that we could further investigate.

    Thank you.

  • Profile Image
    khrisell
    Answered on July 23, 2013 at 06:16 AM

    In addition to my response, I have created a video for you to see how I do it.

    http://screencast.com/t/xqMWYNKP2Ppj

    The problem as I see on your screenshot, you are in edit mode of the title of the dropdown field.

    Kindly follow how I do it on the video.

     

    Let us know if problem persists.

  • Profile Image
    thaisxs
    Answered on July 23, 2013 at 06:21 AM

    hi all i found out what the issue is.... im using chrome and it doesn't allow me to drag but when i switch to IE it does allow me to drag around. 

    r u guys having the same problem on Chrome ? 

     

    and i truly thanks for all the support u guys have provided!

  • Profile Image
    khrisell
    Answered on July 23, 2013 at 06:24 AM

    thaisxs, I am using Chrome.

    Kindly clear your browser cache and cookies and check again if it will work after doing that.

    Thank you

  • Profile Image
    thaisxs
    Answered on July 23, 2013 at 10:05 AM

    Hi i cleared the cookies and cache and still the same. it works fine on IE. I'm not sure if it's because win8 problem. I currently using win 8. 

  • Profile Image
    KadeJM
    Answered on July 23, 2013 at 10:41 AM

    Hello, I just tested this additionally since I also have Win 8 and I am able to drag this around on my test account without any issues.

    Here are my Screenshot Tests of this Change below. The screenshots are taken from your Account when I tested it a Second Time for accuracy.

    You say this is happening in Chrome on your end but not IE it seems. I've additionally cleared your form cache for you but you can also try doing that then edit this again to see if you are still having issues. Also make sure that your Java is Up-to-Date and Enabled since there may be a chance that this might be a related issue because the drag-n-drop ability runs on this.

    Please let us know if this is still a problem for you.

     

    BEFORE:

     

    AFTER:


  • Profile Image
    thaisxs
    Answered on July 24, 2013 at 06:43 AM

    Hi sorry for accidentally posted  a new thread 

    This problem only happened on Windows 8 machine or laptop with touch.

     

    If you're using touch enable pc the drag function will only accept touch input. which mean mouse click will not work on it.

     

    I managed to figure out how to solve this problem. To fixed the problem in short term I've to go to chrome://flags/ to disable touch event. 

    To fix this kind of problem in long term i think jotform will have to make some code changes at the end. you may refer to the link below.

    https://github.com/kangax/fabric.js/issues/670

     

    Hope this help a lil and i really appreciate the help and support u guys have provided to me !!  Thank you