Can't hide "Office Use Only" in my forms

  • Profile Image
    hnhaccreditedtraining
    Asked on July 31, 2020 at 03:30 AM

    I have set up the following forms to allow office input after the form has been filled and submitted by the form user (Student).

    I'm not sure if they are correct as I've copied a form condition from somewhere else.

    https://www.jotform.com/build/202118934838864

    https://www.jotform.com/build/202120351773848

    https://www.jotform.com/build/202118456907860

    Michelle

  • Profile Image
    Richie_P
    Answered on July 31, 2020 at 05:58 AM

    I'm not sure I understood your form requirement correctly.

    Kindly share the flow of your form and how you would like the form to work?

    Looking forward for your response.

  • Profile Image
    hnhaccreditedtraining
    Answered on August 03, 2020 at 01:26 AM

    Hi Richie

    I've created the forms above and the conditions to "hide" the Office Use Only is not working.

    I think I've inserted the "Get Form Page URL widget" in the wrong area.

    See

    https://form.jotform.com/hnhaccreditedtraining/Anglicare-LLN

    https://form.jotform.com/hnhaccreditedtraining/Anglicare-Training-Plan


    I'd appreciate any help to fix this.


    Thanks

    Michelle 

  • Profile Image
    Sonnyfer
    Answered on August 03, 2020 at 03:41 AM

    Hello Michelle - The location of the Get Form Page URL widget is fine. I think it's the condition set that is incorrect.

    To my understanding, you only wish to display the "Office Use only" part of your form when you edit your submissions. If this is correct, then replace the conditions on your forms with the one below:

    1596439983esdq.png

    Give it a try and let us know if you need further assistance.


  • Profile Image
    hnhaccreditedtraining
    Answered on August 03, 2020 at 06:50 AM

    Hi


    I've tried it and its not working. I can't access the "office only" component of the form, clicking with on "Office Use Only" or the URL.

    I've reverted back to a clunky and not professional submit with the Office Use Only visible.

    Our enrolment form works, however this isn't.


    Please help.

  • Profile Image
    Richie_P
    Answered on August 03, 2020 at 08:25 AM

    I have checked your form and I would suggest that you hide your office use only fields by default.

    15964573741.png

    Kindly also use only 1 Get Form Page URL widget in your form to avoid confusion and use the hide/show condition to show the fields when editing the form.

    15964574602.png

    Please give it a try and let us know if you have further questions.

  • Profile Image
    hnhaccreditedtraining
    Answered on August 03, 2020 at 10:47 PM

    I've created a Draft version to play with and followed your instructions.

    https://form.jotform.com/hnhaccreditedtraining/DraftLLN

    1. The Office Use Only is not staying hidden when emailed to recipient, yet it does in Preview mode.


  • Profile Image
    Sonnyfer
    Answered on August 04, 2020 at 12:09 AM

    Hi again - It looks like the reason why it's showing is that your Custom URL has the word "edit". Please refer below:

    1596514089seee.png

    To avoid this from happening, kindly share them your direct form URL instead https://www.jotform.com/form/202158008433851 

    Give it a try and let us know if you need further assistance.

  • Profile Image
    hnhaccreditedtraining
    Answered on August 04, 2020 at 12:21 AM

    Ahh, of course!

    If I change the Value to "office", this now works.


    Thanks

    Michelle