My forms are disabled - and they shouldnt be - and I cant upgrade