Client does not see the credit card form ?

  • Profile Image
    Hanna  
    Asked on August 12, 2020 at 09:43 AM

    I have build the credit card form for client to fill in. I can see it in the build form.

    But client does not see the credit card field ?


    Please help! 

    Thanks,

    Hanna 

  • Profile Image
    enterprisesupportteam
    Answered on August 12, 2020 at 11:25 AM

    Hello Hanna,

    Thank you for contacting our support team.

    I have taken a look at your form and it seems that the payment integration has an error which is causing the credit card field to not appear on your form. Here is a screenshot of the error that I found on your form:

    1597245647Screenshot (416).png

    As you can see, the error message states that your Stripe integration has not been configured yet. To resolve this, you can remove the integration and then reconnect it to allow a refresh to occur. After you reconnect it, make sure to make the correct configurations to allow your integration to receive live payments.

    I will go ahead and provide you with a very helpful user guide to assist you with the Stripe integration: How-to-Integrate-Stripe-with-your-Form

    Please let us know if you have any further questions or concerns, we are always happy to help.

  • Profile Image
    PDACHILD
    Answered on August 12, 2020 at 12:00 PM

    Thanks for. your response.

    I have connect with Stripe, but the client still do not see the credit card field.


    thank,

    Hanna 1597248000thumbnail-2.jpeg

  • Profile Image
    enterprisesupportteam
    Answered on August 12, 2020 at 01:20 PM

    Hi Hanna,

    I see, thank you for the response.

    So, I checked the form once again and it seems that it has become disconnected as the same error message is appearing on my end still.

    Based on the integration, I can see that you have switched from Stripe to Stripe ACH and you have not yet entered the correct credentials for the integration to work. Here is a screenshot of the empty credential fields that I am seeing:

    1597252700Screenshot (417).png

    Kindly fill in the credentials for your Stripe ACH integration and test the form again.

    For more information on the Stripe ACH integration, please use the following user guide to assist you: How-to-integrate-Stripe-ACH-to-your-form

    We look forward to your response.

  • Profile Image
    PDACHILD
    Answered on August 12, 2020 at 01:30 PM

    I switched to Stripe ACH by mistake, and have switched back to Stripe.

    But still not work, client still cannot see the credit card field.

    Thanks for  your response.




  • Profile Image
    John
    Answered on August 12, 2020 at 04:14 PM

    Looks like an issue with the theme. I can see that the Stripe field is properly configured on your form, but can't see the credit card field either when I access the published version.

    Could you please try switching to a different theme then revert to the default theme? That should reset the form styling and might resolve the issue. 

    15972632222507651.png

    Also, your form logo will be removed once you switch themes. You may re-upload it after reverting to the default them.

    Please try that and let us know how it goes.