What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    iOS 6 - iPhone cannot Upload when Multiple Files option is Allowed

    Asked by Alhambra on August 03, 2013 at 02:58 AM

    After extensive testing today, I've narrowed the file-upload trouble/issue to iPhones and File-Upload with the setting to allow multiple files.

    Oddly, it actually worked fine on my iPod Touch (Gen 4).  And iPads are fine.

    But for the iPhone, the error message:

    "IMG_2107.mov is empty, pleas select files again without it."

     

    To duplicate the problem: Simply make a form with File Upload (allow multiple), try to upload from iPhone.

    in my account there's "File Upload Test" all ready for testing.

    Form# 32136706411849

     

    Related note, in case relevant to people reading this thread: I wanted to add that I came across an iOS file-upload issues a couple weeks ago that was only solved by making the SUBMIT button-style plain/no formatting (bottom-right).

     

    Thanks,

    Jason

    Founder/CEO

    CoachMyVideo

    Screenshot
    ios problem style message mov
  • Profile Image
    JotForm Support

    Answered by Welvin on August 03, 2013 at 07:52 AM

    Hi Jason,

    This is a known issue to the limitation of iOS and Android Browsers.

    Can you please define the extension instead of allowing all file types (the asterisk)? Put "mov" and "MOV", small caps and all caps. Make sure to separate the two using comma then space. Please try that and let us know for the result. I am contacting my colleague who owns an iPhone to help us troubleshoot the issue. 

    Otherwise, I would suggest using the Single File upload. Ths should work for your device.

    Thanks

  • Profile Image

    Answered by Alhambra on August 04, 2013 at 11:50 PM

    Welvin,

    I appreciate your quick follow-up on this.

    I changed the validation from "*" to "mov, MOV" and no change: same error message as above. I tested with and without image validation.

    You mentioned it is a known issue of iOS, but just to be clear, for others in the forum, the Allow Multiple uploads option works properly on iPad and iPod touch in my testing via Safari. however it does NOT work for iPhone users attempting to upload even one file.

    You guys have a fantastic product with JotForm, and if this can be fixed for the iPhone users out there, it will be even better for video-uploading users. (~380mn + iPhones sold to date)

    Thanks - I look fwd to hearing if there's a fix coming.  From what I understand, iOS 7 is no different with respect to this issue.

     

    -J

    IMPORTANT NOTE for iOS users / video uploader: on my iPad Mini iOS 6/Safari: there is another important difference between the two upload options. The ALLOW MULTIPLE does NOT automatically force video compression (360p) as does the single-upload button.  This means the user can upload the video as it is recorded (up to 1080p and very large in size)

    The Single-File-Upload option causes all videos to be compressed before upload. They will thus be limited to a little under one minute in length to keep the file-size under around 10MB - this is same thing you have seen when you attempt to email a video out of our Camera Roll - even a short one.

    if you are curious enough to dig into the nuances of file-sizes for iOS, our free CoachMyVideo App gives you some email sharing options to play around with to compare video resolution and compression when emailing, or see our FAQ page to estimate uncompressed videos in iOS devices (vs. compression down to to 360p with time-limit which keeps it under 10-min)

  • Profile Image
    JotForm Support

    Answered by Welvin on August 05, 2013 at 01:47 AM

    Hi Jason,

    Yes, that is specifically happening for iPhone. If you'll check all other threads, they have this problem with iPhone. An alternative is to download another browser such as Chrome for iPhone or Opera. 

    Thanks