What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Can you please clear the form cache for this form?

    Asked by wengriffinapt on August 13, 2013 at 02:03 PM

    http://form.jotformpro.com/form/30145225364951

    It's embedded into a web page, but keeps freezing and the submissions seem to go through, but the page keeps saying please wait. 

    Page URL:
    http://mitchell1epay.com/requestmoreinfo.html

    cache Submissions please wait freezing embedded iframe
  • Profile Image
    JotForm Support

    Answered by KadeJM on August 13, 2013 at 03:09 PM

    Hello, I've checked your form and also cleared your form cache for you. You are more then welcome to clear the form cache yourself by following the instructions for this in this guide here: http://www.jotform.com/help/229-How-to-Clear-your-Form-Cache. If it is still giving you issues freezing and such then I would highly suggest embedding the form within an iFrame since it sounds like there is most likely a script conflict on your webpage so this will help to prevent that issue from reoccurring. But if it is still continuing thereafter then may we have your permission to test it further? Please let us know.

  • Profile Image
    JotForm Support

    Answered by Mike_T on August 13, 2013 at 03:19 PM

    We are very sorry for the inconveniences caused.

    It looks like that something might be wrong with that 'Mitchell1 Microsite Contact Form 082013 (request more info form)'. We have made several tests, but unfortunately, it is not quite clear why the Thank You Redirect is not working every time upon submission.

    However, it seems that form Cloning might solve the issue. Can you please clone your form, and test the cloned version?

    Thank you.

  • Profile Image

    Answered by wengriffinapt on August 13, 2013 at 03:25 PM

    I did... I also embedded the form using an iframe. I am still having the same issue. The submission goes through but the page does not redirect to the thank you page. This form has worked hundreds of times and now it's not. I didn't change anything on my end. What should I do now? 

  • Profile Image
    JotForm Support

    Answered by EltonCris on August 13, 2013 at 03:57 PM

    @wengriffinapt

    Our apologies for this inconvenience.

    Have you tried Mike's suggestion? I have cloned your form here and it works just fine so perhaps the cloned form would help. Guide: How to Clone an Existing Form

    Here's my cloned form: http://form.jotform.com/form/32245805882963?

    Let us know how it goes. Thanks!

  • Profile Image

    Answered by wengriffinapt on August 13, 2013 at 04:22 PM

    I have cloned the form and embedded it, but I am still having the same issue. Is my only option to use an iframe? 

  • Profile Image

    Answered by wengriffinapt on August 13, 2013 at 04:31 PM

    I have cloned the form to an entirely new clone and used iframe and am still having the same issue. PLEASE HELP!!! 

  • Profile Image
    JotForm Support

    Answered by KadeJM on August 13, 2013 at 05:07 PM

    Hello and thank you for letting us know, I'm sorry to hear that this is still giving you problems. I can see that it's still hanging up as also. I've looked into this issue some more and I think that this is happening because of a problem with our server. I noticed that your using our domain JotFormPro.com and even when I used just your form by itself it was still the same problem instead of on your website so that eliminates that as a problem. When I checked this by cloning your form this swapped the form to my domain which is JotForm.us or Form.JotForm.us and it's working alright.

    Did this problem just start today or how long ago has this been occurring now? I'm convinced at the moment that this is most likely happening due to heavy traffic we are experiencing today which could explain the reason for this lag in server response times.

    The reason I saw that is after I checked your form just now I could see that even though it appears to be freezing up it is not since the submissions are going through. It seems that the submit button is just lagging out or timing out for some reason.

  • Profile Image
    JotForm Support

    Answered by KadeJM on August 13, 2013 at 05:13 PM

    Furthermore, I would suggest that for the moment you wait a little while longer since it is almost the end of our server peaktimes which is currently from about 8am til about 6pm EST in about an hour or so and then if it is continuing please let us know so that we can check on it again.

    Additionally my colleague pointed out that it's not our Server since when he cloned your form it was also on JotFormPro which is the same server your form. So I'm not so sure that this was any part of the issue now that my colleague has pointed this out. 

    Please keep us updated if the problem continues after awhile.

  • Profile Image

    Answered by wengriffinapt on August 13, 2013 at 05:49 PM

    Thank you very much for the email. The issue started occurring on Friday
    morning (11am PST) August 9. This issue so far as we can tell is only
    occurring with two of our forms. Both happen to be for the same thing. Can
    you provide any kind of estimated time frame for when this issue will be
    resolved? Please advise at your earliest possible convenience and thank you
    again for the update.

  • Profile Image

    Answered by wengriffinapt on August 13, 2013 at 06:53 PM

    I have resolved this issue by rebuilding the form from scratch. I really should not have had to do that, but in the future if I encounter this issue again, that's how I'm going to resolve it. 

    No further action is needed from you all. 

  • Profile Image
    JotForm Support

    Answered by Welvin on August 13, 2013 at 06:53 PM

    Sorry to test your form without asking. As far as I can see, the form is now working fine. It's just a temporary server timeout which will only last a few minutes. Or, sometimes a form caching issue which can be fixed by clearing your forms cache.

    Please try to re-embed your form using this codes:

    <iframe id="JotFormIFrame" allowtransparency="true" src="//form.jotformpro.com/form/32246007360949" frameborder="0" style="width:100%; height:780px; border:none;" scrolling="no"></iframe>

    This code is for this page: http://mitchell1epay.com/requestmoreinfo.html.

    See if that makes a difference. If yes, I would suggest doing the same - to remove the script tags out from the form iframe codes.

    thanks