What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Script Error with all Embedded JotForm forms.

    Asked by tdiintl on August 15, 2013 at 11:11 AM

    In my web editing software I'm getting an error (see attached).  This has never come up before, it started yesterday in addition to another problem I'm having (different thread for that separate problem, although I don't know if they are related). 

    Can anyone tell me why this might be happening and what I can do to fix??

    Please note it's happening on EVERY form, not just the example I've included.  Thank you.

    Page URL:
    http://www.tdiinternational.com/contents/en-us/d600_160d-desiccator.ht<br/>ml

    Screenshot
    JotForm problem different addition attached
  • Profile Image
    JotForm Support

    Answered by KadeJM on August 15, 2013 at 02:47 PM

    Yes I see what you mean and I know this was referenced from your other thread herehttp://www.jotform.com/answers/256384-My-captcha-at-the-bottom-of-some-forms-wont-load#7. Is this also occurring in IE8 on your end as well? I've been prodding through some of your page source code with my own tests to try to replicate the problem but so far no luck. 

    Could you please describe to us the steps that you took for when this Scripting Error happened?

  • Profile Image

    Answered by tdiintl on August 15, 2013 at 02:59 PM

    This error isn't coming up in any browser, it's in my web editing software.  I'm using ShopFactory and when I click on any page with a jotform embedded that's when I'm getting the script error.  If I click Ok it seems alright, but I've never had this or any other error before.  Seems very strange that it happened in tandem with the other problem I'm having.

  • Profile Image
    JotForm Support

    Answered by KadeJM on August 15, 2013 at 04:14 PM

    Okay thank you for the additional information about that. I'm not too certain about it at the moment because of the fact that you mentioned its happening in ShopFactory CMS so I think that this could be a misread with the script for their System. Usually this Script Error is the result of a code conflict with the form and some code or scripts on your webpage or in this case it may be a small problem because of the CMS if you haven't noticed anything else out of the ordinary. It's very obvious though that this is a definately a code conflict of some sort that is happening somewhere.

    You can refer to this thread for additional details as to what I am talking about in regards to this.

    Anyhow we are still inspecting your original issue and I will note this in addition to that for reference to look into this as well. It is going to take us a little bit longer to try to figure this out but we will do our best to get to the bottom of both issues. We will notify you as soon as we know something further so until then we will be greatful for anymore patience that you can give us for now. If necessary though, we will open this thread into a Ticket to be investigated deeper by our Development Team but we will keep you notified either way.

  • Profile Image
    JotForm Support

    Answered by KadeJM on August 15, 2013 at 04:20 PM

    Is this http://www.shopfactory.com/ the ShopFactory you are talking about? Can you please confirm this?

  • Profile Image

    Answered by tdiintl on August 15, 2013 at 04:24 PM

    Thank you, thank you!  Yes that is the ShopFactory I'm using, Version 9 Pro if that helps.  I have no problem being patient if I know its being looked into.  I really appreciate it.

    I did try removing other scripts I had on one of the pages to see if there was a conflict, to no avail so it's not anything I'm adding manually.  ShopFactory does have a lot of things that are not editable or really accessible, so it could be something in there.

  • Profile Image
    JotForm Support

    Answered by Welvin on August 15, 2013 at 06:34 PM

    Hi,

    That is probably a script conflict. Our iFrame Embed method would resolve an issue like this. Please try to switch your embed codes to this method: How to Get Form iFrame Codes.

    In the Form iFrame Codes, remove the scripts tags. The iFrame codes will looks like this:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//form.jotform.co/form/32245189212854" frameborder="0" style="width:100%; height:465px; border:none;" scrolling="no"></iframe>

    <script type="text/javascript">window.handleIFrameMessage = function(e) {var args = e.data.split(":");var iframe = document.getElementById("JotFormIFrame");if (!iframe)return;switch (args[0]) {case "scrollIntoView":iframe.scrollIntoView();break;case "setHeight":iframe.style.height = args[1] + "px";break;}};if (window.addEventListener) {window.addEventListener("message", handleIFrameMessage, false);} else if (window.attachEvent) {window.attachEvent("onmessage", handleIFrameMessage);}</script>

    Remove the codes highlighted in YEllow.

    Thanks