What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    After editing a submission and selecting submit the Form goes to blank page

    Asked by seaba on August 19, 2013 at 04:15 PM

    After data is submitted on my Volunteer Signup form, I contact the volunteer and edit the data in the Contact Notes field.  When I hit the equivalent of my Submit button (or hit "Return"), the entry disappears entirely from my screen and I am left with a completely blank space in the window area where the form & data were.  The data is updated, but I cannot see the changes in the data or in the grid below unless I go back to "My Forms" and bring up the form and that entry again.  

    A year ago, when I used this same form (with only minor changes for this year), it worked fine.  I could immediately see the changes on both the edit screen and in the grid below.  Seems like a bug has been introduced?

    I am using Google Chrome Version 28.0.1500.95 on a Mac. 

    Page URL:
    http://form.jotformpro.com/form/22664631292959

    My Forms blank space Updated same form
  • Profile Image

    Answered by zenmatrix83 on August 19, 2013 at 05:10 PM

    Try clicking on setup and embed and then click on thank you. Click on the bottom option where you can send them to a message and then just save it. It may just need to resave it, I copied your form and was able to see the issue.

  • Profile Image

    Answered by seaba on August 19, 2013 at 05:41 PM

    Thanks, but it's not the thank you message I'm concerned about.  I'm talking about going in and editing data already submitted on the form.  I view the submission, click on Edit, modify the value in the Contact Notes field, and hit the Submit button.  The entire viewing area goes blank, and neither the data in the grid nor in the form appears to be updated (although it really is) until I go back into "My Forms" and bring up the form and entry again.  

  • Profile Image

    Answered by zenmatrix83 on August 19, 2013 at 06:15 PM

    Seems to be an issue with chrome, I get the same thing using windows 7 and chrome but not firefox

  • Profile Image

    Answered by seaba on August 19, 2013 at 07:39 PM

    I have the problem whether I'm using Chrome, Firefox or Safari. 

  • Profile Image
    JotForm Support

    Answered by Tasha on August 19, 2013 at 10:00 PM

    @Seaba

    Thanks for letting us know about this problem and I am sorry for any inconvenience that this may have caused. I was able to reproduce the issue in both Chrome and Safari and will be passing the information along to our developers for a resolution.

    In the mean time I did verify that the submission was actually saved even though you get a blank page and you can also refresh the page after you have submitted the form to see the updates. It also works fine in IE10 and Firefox 22.0

    Once our developers resolve this issue we will update this thread.

    Thanks!

  • Profile Image

    Answered by seaba on August 20, 2013 at 06:59 AM

    I usually hit F5 to refresh my screen, but that hasn't worked either.  Is there another way to refresh so I can see my editing changes?

    Thanks for looking into this!

  • Profile Image

    Answered by jeanettebmz on August 20, 2013 at 11:02 AM

    I would recommend you to use the incognito window feature that comes in Chrome.  I've cleared your forms cache. You can do that in your side, by going to My Account Settings and clearing your forms cache

  • Profile Image
    JotForm Support

    Answered by alp_deniz on August 28, 2013 at 06:30 PM

    Hello Seaba,

    Thank you very much for your report. It is fixed and should be working fine now.

    Kind regards

  • Profile Image

    Answered by seaba on August 29, 2013 at 05:09 PM

    It is indeed fixed and working beautifully!  Thx so much!