What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Purchase Order Tool: Huge Space and Wierd Character

    Asked by SFDCERT on August 21, 2013 at 02:36 PM

    I'm using the purchase order payment tool, and I'm finding an issue in the data that's being stored.  I've reproduced this in multiple forms - trying to figure out where it's coming from and if I can filter it out.

    When I submit an order, in Excel there is some kind of odd spacing and a hidden character return, but not at the end of each item.  I don't see it on the web page showing me my submission data:

     

    But the PDF that is generated has the carriage return:

    ...as does the .xls file I download:

    What is this and how do I filter it out?  Doing it by hand is a pain...I tried selecting everything between the last character and the close peren ")" and do a "find/replace", but Excel doesn't find that string - even though I select just that string in the text.

    Excel also doesn't recognize the 13 spaces in that same string.

    excel submission data purchase hidden payment tool
  • Profile Image

    Answered by jeanettebmz on August 21, 2013 at 05:48 PM

    Looks like you are a great tester and we really appreciate you report this to us

    I got a question for you, have you tried downloading the CSV version of the report? Is this happening only with Purchase Orders?

    At any rate, I'll make a test on this and will get back to you to tell what would be the outcome and solution for this

  • Profile Image

    Answered by SFDCERT on August 21, 2013 at 06:12 PM

    ...same thing via CSV:

  • Profile Image

    Answered by SFDCERT on August 21, 2013 at 06:20 PM

    ...I don't see it happening with other forms, but the other forms we have are just entry forms - no other Purchase forms.

  • Profile Image

    Answered by jeanettebmz on August 22, 2013 at 12:03 AM

    We are testing this, it doesn't happen to me in my Ubuntu PDF or Spreadsheet viewer. However, I've assigned this to another supporter with MS OFFICE , so if we reproduce the problem we will report this to our 2nd level engineers

  • Profile Image

    Answered by jeanettebmz on August 22, 2013 at 12:16 AM

    As a matter of fact. I added more options to my test form , I downloaded the CSV report and opened in my OpenOffice app with no problem. So it might be definitely an issue with MS-EXCEL. Can you please tell which version you are using?

    Also, can you tell if while converting the CSV file, did you bring it comma separated and using Character Code UNICODE UTF-8  ?

  • Profile Image

    Answered by SFDCERT on August 22, 2013 at 03:07 AM

    ...that doesn't explain why it appears on the PDF...the PDF is generated on your side then downloaded.

    I'm working with Excel 2010.

    I don't do any conversion, I download it as a .csv and open it directly in Excel.

    The problem seems to be expanding now...I just downloaded the submissions, and one of them shows results on the Jotform web page, but no data is coming out on the .xls download.  WHY can I see it on JotForm's web site AND on the PDF, but now data is coming up missing in the .xls file?!

    As for converting...I'm not.  I tell Excel to open the file and it does - there is no "bringing it in" step in 2010, it reads it and opens it - I don't have to specify anything.

     

    ...seriously guys...if this is how it's going to be...the form works but can't export data, and then starts losing data for no reason, then why should I continue to use (and publicly endorse) your product?

  • Profile Image

    Answered by SFDCERT on August 22, 2013 at 11:53 AM

    I can reproduce this effect on two different machines with two different installs of Office 2010.

    What version of Excel are YOU using?

  • Profile Image
    JotForm Support

    Answered by Welvin on August 22, 2013 at 12:21 PM

    Hi,

    Good day! I can't really tell what's causing this to your form. I've clone the form and can reproduce the issue, but NOT with my new form using the same format and product items and settings.

    -Can you please name us the submission ID of this missing data so we can check?

    -We will try to check this again later today. As I have mentioned above, I can't replicate this with a newly created form so there might be some glitch with your current form that causes this issue to happen. 

    I'm using Office 2010.

    Thanks for your patience and understanding.

  • Profile Image

    Answered by Sacramento CERT on August 22, 2013 at 01:01 PM

    I've already deleted the record having the issue and had to resubmit (using up another submission).

    I have to say, this whole "clone" issue is getting annoying.  If you "clone" a form, by definition shouldn't that be copying the form EXACTLY - flaws and all?

    Magically cloning the form and having the issue go away sounds to me like you have some other issues in your structure.  Either a) the "clone" function is doing more than just copying the form and/or b) there is somethign in your structure that is causing the forms to corrupt without modification.

    Either way, it's troubling.  We shouldn't have to keep cloning forms we haven't modified in any way, then post that new link on our own web pages just to keep operations working.  That's a lot of work to keep on top of, and we may miss orders due to a glitch outside of our control.

  • Profile Image

    Answered by SFDCERT on August 22, 2013 at 01:21 PM

    Are you adding custom pricing??  I don't see the mystery characters/carriage return on items that don't have the custom pricing option...

  • Profile Image

    Answered by SFDCERT on August 22, 2013 at 01:22 PM

    I just checked that 'sample form' that the manager said works fine...she didn't include custom pricing either.

     

    If you guys are going to claim to reproduce our forms, you should reproduce them accurately.

  • Profile Image

    Answered by SFDCERT on August 22, 2013 at 01:35 PM

    Just to play along, I just cloned the form and entered a new submission on the new form...guess what?  THE MYSTERY CARRIAGE RETURN STILL APPEARS IN BOTH DOWNLOADS AND ON THE PDF AND ON THE SCREEN!!

    This PROVES this isn't on my end...if the character is showing up on your own web page display, HOW can it be a translation error in Excel??!

  • Profile Image
    JotForm Support

    Answered by Welvin on August 22, 2013 at 04:48 PM

    Hi,

    I've recreated the form with just a few items. I will come back to you later today for the additional items so you can use this instead of the current form.

    http://www.jotformpro.com/form/32336012798960

    It's like a bug within that form. I'm trying to locate that but failed to do so.

    Please have us your patience.

    Thanks

  • Profile Image
    JotForm Support

    Answered by Welvin on September 04, 2013 at 12:21 AM

    Sorry for taking too long, I have updated the form. Please kindly check this v6 form: http://www.jotformpro.com/form/32334943824961

    Thanks

  • Profile Image

    Answered by SFDCERT on September 18, 2013 at 12:59 PM

    Umm...where exactly does that form go?  I don't see it on my side...how can I check it if it's not my form?

  • Profile Image
    JotForm Support

    Answered by Welvin on September 18, 2013 at 02:02 PM

    So sorry. That form is created under my guest account. We are restricted to do a modification on user's form and create/clone forms to users account without authorization. 

    You'll have to clone it back by following this guide: How to Clone a Form.

    Thanks