What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Can't upload a file on MS Internet Explorer ?

    Asked by go4real on August 31, 2013 at 01:02 AM

     

    JotForm is really good form.

    The only thing I want to improve is file uploading function in MS internet explorer.

    I did some file upload tests there; however, it didn't work for me.

    Any solution for this~?

     

    Thanks in advance

    JotForm thanks solution
  • Profile Image
    JotForm Support

    Answered by EltonCris on August 31, 2013 at 03:22 AM

    Hi,

    What IE version are you using? Our upload tool supports all browsers. You can pick and upload files using our single/multiple file upload tool. Though, I believed IE browsers doesn't support multiple uploading of files. This is just how it works in this browser.

    Can you give us further details on what error comes or how does the file upload fails on IE? We'd be so much glad to investigate it further.

    Thanks!

  • Profile Image

    Answered by go4real on August 31, 2013 at 05:28 AM
    The version of IE is 9.
    The file is uploaded but doesn't dismiss.
    And the status of the button changed 'Uploaded!'
    When I exit the upload popup with 'x'button on the right-top, no file is
    uploaded.
    2013/8/31 JotForm Support Forum
  • Profile Image
    JotForm Support

    Answered by Goldo on August 31, 2013 at 05:03 PM

    You are referring to form id: 32421845519455 right? What is the extension and file size you are trying to upload so we can try to replicate? Have you tried uploading small size files?

    I did try to upload an image and it was a success. Please try and let us know.

  • Profile Image

    Answered by go4real on September 02, 2013 at 03:28 AM
    Thank you for your concern.
    Actually I've tried uploading variety of files with different size and type.
    I've attached screen shots.
    2013/9/1 JotForm Support Forum
  • Profile Image

    Answered by EliezerN on September 02, 2013 at 11:32 AM

    @go4real

    Ufortunately we can't see your iages as our forum doesn't support attached files. You can upload your images using this tool of Jotform and then sharing the links here.

    I cloned your form and tested it using IE9 and i had no problems uploading a file, Please see this video:

    https://shots.jotform.com/eliezer/Screen%20Captures/uploading_images__.swf

    This was the result I received in the email:

    This is my cloned form: https://www.jotform.com/form/32444133573955

    So, I wonder if you've embeded your form to any webpage. If so you should re-embed it using the iFrame code to do it, because it's probably that some script of your form is getting in conflict with your webpage. Please refer this guide to know about Getting the form iFrame Code

    If you need further assistance please let us know.

    Thanks