When I embed source code Page Breaks Do Not Work

  • Profile Image
    bigbudgie
    Asked on September 02, 2013 at 03:28 AM

    Hello,

    I am trying a new form and have created a form with page breaks,

    When I add the "source code" from the embed options the page breaks show but do not function. (the mouse can see them as it high lights the button but when you click nothing happens.

     

    The rest of the form including the send button all work - it is just the page breaks "next" and Back"

    NB

    The form works when I just use the "embed" code

    I wish to use the source as the forms seem to load better.

     

    Many thanks

     

    Bigbudgie

  • Profile Image
    ashwin_d
    Answered on September 02, 2013 at 08:38 AM

    Hello Bigbudgie,

    Please try to re-embed your form again with your form's source code. There are few JavaScript's references are missing in your website where you have added your form's source code. 

    Here are the steps to get your form's complete source code:

    1. Load your form in form editor.

    2. In the form tool bar, click on "Setup & Embed"

    3. Click on "Embed Form"

    4. Click on "Source" to get your form's source code:

    Download this code and add it without removing any js/css references.

     

    Thank you!

  • Profile Image
    bigbudgie
    Answered on September 02, 2013 at 09:25 AM
    HelloThank you for your reply,I have done as you have requested, clicked source code; source code is high-lighted copied and pasted this in to my website but it the next button do not function,
    I also highlighted it and scrolled through to make sure I copied all the code but still the next button does not function.
    http://grantschemes.co.uk/test.html
    What am I doing wrong?
    Many thanks
    Date: Mon, 2 Sep 2013 08:38:05 -0400
    To: laurieyeates@hotmail.co.uk
    Subject: Re: When I embed source code Page Breaks Do Not Work
  • Profile Image
    ashwin_d
    Answered on September 02, 2013 at 01:05 PM

    Hello bigbudgie,

    Most likely there is a code conflict in your webpage code where your form is embed.

    How about using a iframe to embed your form? If you want your form source code to be hosted in your server, you can still use iframe to embed your form.

    Here are the steps:

    1. Follow this guide to download your form's complete source codehttp://www.jotform.com/help/104-How-to-Download-a-Source-Code-of-your-Form

    2. Save/upload all files (.js/css and html) in your own server.

    3. Find out the url to your html file which you have saved to your server (in step 2).

    4. Copy the below code in your webpage where you want to embed your form:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="http://www.grantschemes.co.uk/custom/jotform-static.html"frameborder="0" style="width:270px; height:321px; border:none;" scrolling="no"></iframe>

    5. Replace the bolded text in above text with the code/url which you got in step 4.

    Hope this helps.

    Thank you!