Submit button not working

  • Profile Image
    pattysmusthavenails
    Asked on October 26, 2020 at 08:29 AM

    customers are saying that the form says please wait & freezes when they hit the submit button. this has been a recurring problem. what is the issue and how can we fix it. 

    thank you. 

  • Profile Image
    VincentJay
    Answered on October 26, 2020 at 10:01 AM

    Hi,

    Is the form embedded on a website? Also, is it okay if we submit a test submission to your form?

    We'll wait for your reply. Thank you!

    I cloned your form and I was not able to replicate the issue. Please check my screencast below:

    1603720907_5f96d6cb620de_jhkul.gif

  • Profile Image
    pattysmusthavenails
    Answered on October 26, 2020 at 10:28 AM

    it is not embedded on a website. Yes please test form

  • Profile Image
    VincentJay
    Answered on October 26, 2020 at 12:20 PM

    Hello,

    I tried submitting a test submission and I was able to replicate it. The form didn't submit and it is stuck to the "Please Wait" button.

    1603729114_5f96f6da6aae0_vnf44s.gif

    Please try this, remove the Google Spreadsheet integration, and test the form. After that, add the Google Spreadsheet integration again and test the form. If the issue still persists, please let us know.

    Thank you!

  • Profile Image
    pattysmusthavenails
    Answered on October 26, 2020 at 04:56 PM

    Removed as suggested, still not working. I haven’t added it back if you’d like to keep troubleshooting

  • Profile Image
    VincentJay
    Answered on October 26, 2020 at 06:09 PM

    Thank you for removing it.

    I tested it and I was not able to replicate the issue. Could you please check and try this cloned form (https://www.jotform.com/202994263600959) and let us know if the issue still persists on your end?

    1603750158_5f97490e7df97_vbhgfh.gif

    We will just wait for your reply and we will forward this issue to our developers.

  • Profile Image
    pattysmusthavenails
    Answered on October 26, 2020 at 08:08 PM

    I added it back and tested and still not working

  • Profile Image
    roneet
    Answered on October 26, 2020 at 11:44 PM

    Could you please let us know further details on how the form is opened in the mobile browser?

    Is the issue occurring only in Apple devices or Android phones too?

    Is the user directly clicking on the link shared via the email that leads the form to open in the Safari browser? or the link opened via any Social networking site?

    Looking forward to your response.

    Thanks.

  • Profile Image
    pattysmusthavenails
    Answered on October 28, 2020 at 08:22 PM

    i have an iPhone, but the customer who had issues and and Android. I’ve also tried on a computer through internet explorer and encountered the same problem

  • Profile Image
    roneet
    Answered on October 28, 2020 at 10:07 PM

    Could you please update all the Gift Registry widget and see if that makes a difference:

    1603937233_5f9a23d110f01_

    Let us know how it goes.

    Thanks.

  • Profile Image
    pattysmusthavenails
    Answered on October 28, 2020 at 11:26 PM

    That worked!! Thank you!!