Survey Question Conditions

  • Profile Image
    KateOMurphy
    Asked on October 27, 2020 at 03:09 PM

    Hello,


    I am having trouble with the Conditions I am setting for my survey; they do not seem to be working. For example, I set a Condition that if a response to a particular question is equal to YES, then Disable Submit. However, when testing this, I am still about to submit when my response is YES.


    I even tried going about it the other way. I set the Condition as when the response to a particular question Is Not Equal To No, then disable submit. This did not work either.


    Thank you.

  • Profile Image
    Basil_A
    Answered on October 27, 2020 at 05:31 PM

    Hi,

    If you are just trying to make that user's are filling the fields, you can set the fields to required from each field's settings.

    Guide:

    https://www.jotform.com/help/546-how-to-set-a-field-as-required-or-non-required

    Regarding your conditions, condition work in a way that if the condition is not met then the condition does the opposite, that is why your conditions are contradicting each other, some are fulfilled so they disable the button others aren't so they enable the submit button.

    I would suggest adding all your conditions in one condition with the option any of the conditions is matched if you do not want to set the fields to be required.

    Please look at the condition below:

    1603834162_5f9891323ebad_chrome_hXGq41YH

    Setting up a similar condition and adding the rest of your conditions should work for your form.

    Please let us know if you have any further questions.