Problems accessing my form

  • Profile Image
    Asked on September 26, 2013 at 05:13 AM

    Hi there,

    I was wondering if you could help me with the following issue - whenever I log into your page and try to access forms I have created and that are working, I cannot access them.

    There is one particular form called "Preliminary Employee Intentions Survey" which I need to change slightly before it gets published, but I do not have access. Also For some weird reason when I select form templates tab - I see only emty page with no templates.

    I have tried  opening Jotform page with different browsers: Firefox, IE and Chrome, tried secured addresses you are suggesting on Support Forum, but it still does not work.

    I have attached two screen shots:

    1) my forms

    2) form templates - unfotunately can upload only one screen shot at a time - so I did not appload this one, but I got absolutely empty grey screen

    Any idea how htis can be solved? Of course I can recreate the form in order to post it the eway I need, but that does not solve the issue in general. Any advise? Thank you!

  • Profile Image
    Answered on September 26, 2013 at 06:47 AM

    I have checked your account and tried to edit the said form and I was able to. You mention that you have tried to use different browsers, have you tried to clear your browsers cache before logging in and see if it resolves the issue?

  • Profile Image
    Answered on September 26, 2013 at 08:01 AM

    The problem still persists - I cannot access my forms at all, I recreated the form, because I really need to start using it tomorrow, so I have the link. But the problem is still here. In all browsers caches are cleared automatically when the browser is closed. But I opened the browsers and cleared each cache again.

    Unfortunately nothing has changed. Any other ideas? When you log into my account, can you access all my forms? Thanks!

  • Profile Image
    Answered on September 26, 2013 at 08:22 AM

    Hello Ineta,

    Upon checking your account, I didn't find any issue. I was able to access all your forms.

    Do you still have this problem? I see that you have been editing your forms today. See the historical records here:

    If the issue persists, can you please login to your Jotform account using non secure domain i.e. instead of and let us know the results.

    Thank you!