Form Submit Stuck on "Please wait..."

  • Profile Image
    nrasmus
    Asked on December 01, 2020 at 10:27 AM

    Hi there,


    Edit: the form seems to be accepting submissions again, though nothing was changed functionally on the forms. Clones of the forms with nothing altered also work fine. Is it possible that there's an issue with an influx of traffic to the forms and Jotform's processing on the backend? There's quite a bit of logic on the backend to make the forms functional and convenient. We noticed and accepted initially that it would take some time to load the form, but we've never had an instance where the form functions fine, but fails submission.


    We're experiencing an issue with several forms where submission is not working. The user can get through the form process just fine, but upon hitting Submit the form hangs on "Please wait..." and never makes it to the confirmation page.

    This is a critical issue for us, as we're using Jotform to manage registrations for our virtual events, which are quite popular.

    This is happening on both of our event forms, across all events, but here are two specific instances for testing:

    https://form.jotform.com/202124631384144?EventID=Cooking%20with%20Katie%20-%20December%2012th

    https://form.jotform.com/202035224791145?EventID=Frost%20Fest%3A%20Book%20Lovers%20Trivia


    It appears as though all the necessary data is loading, as it wouldn't allow the user to get to the submit button if it wasn't. Is it possible there's an issue on the backend preventing the submissions from going through?


    Thanks for your help,

    Josh

    Screenshot
  • Profile Image
    nrasmus
    Answered on December 01, 2020 at 11:20 AM

    Just as a followup:

    The forms seem to be accepting submissions again, though nothing was changed functionally on the forms. Clones of the forms with nothing altered also work fine.

    Is it possible that there's an issue with an influx of traffic to the forms and Jotform's processing on the backend?

    There's quite a bit of logic on the backend to make the forms functional and convenient. We noticed and accepted initially that it would take some time to load the form, but we've never had an instance where the form functions fine, but fails submission.

  • Profile Image
    Rehan_F
    Answered on December 01, 2020 at 01:29 PM

    Greetings Josh,

    Our backend team has fixed the issue already. Please accept our apologies for the inconvenience this might have caused.

    Should you need further assistance, please let us know.

    Thanks.