I've created a dozen forms with no problem, but now it's stuck...

  • Profile Image
    skoutal
    Asked on December 02, 2020 at 06:33 PM

    ...saying, "This might take a while, hang tight."

    It's been more than 5 minutes. It has never taken this long. It's only a 2 page PDF. It has a bunch of lines and some hand-written material, but I never imagined it would take this long.

    Please advise.

    Thank you,

    Sam

  • Profile Image
    skoutal
    Answered on December 02, 2020 at 06:42 PM

    I've tried stopping and restarting. I've tried logging out and back in and starging over. Nothing helps.

  • Profile Image
    skoutal
    Answered on December 02, 2020 at 08:03 PM

    This PDF was created using my Android phone and Google Drive. I scanned it to a PDF in my drive from my phone. It still hasn't been created.

    To make it work, I took a screenshot of the PDF on my computer and pasted the pages into Word. Then, I saved it as a PDF and uploaded it to Jotform and it worked quickly.

    Any idea what the problem is?

  • Profile Image
    Gaetan_B
    Answered on December 02, 2020 at 10:30 PM

    Hello Sam,

    Thank you for reaching out.


    I haven't been able to reproduce the issue, I can successfully upload a PDF.


    Maybe it was a temporary glitch, could you please try again?


    If it does not work, could you please clear out your cache?

    Here's a guide on how to do it on Chrome: Clear cache & cookies on Google Chrome.


    Should you have any further inquiries, please don't hesitate to reply to this thread.

    Gaetan