What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Hide Empty Fields Not Working

    Asked by sefaa on October 01, 2013 at 12:38 PM

    I've enabled the Hide Empty Fields option on my submissions. It hides almost everything except "Address of Community" which is asked on several pages of our form, so it is appearing a couple dozen times on the PDF of the submission data (empty - except for the one they filled out on the appropriate page).

    I don't believe I made any modification to the default. Why is it hiding almost all of the fields except for this one?

     

    Please help! :)

    Page URL:
    http://form.jotformpro.com/form/32175634917964

    Screenshot
    hide empty fields Submissions submission data
  • Profile Image

    Answered by EliezerN on October 01, 2013 at 02:20 PM

    Thanks for contacting us.

    I cloned your form and made some tests. I found that you have all the "community" fields as required fields, that's why the "Hide Empty Fields" doesn't work.

     

    I sent a submission test with my cloned form and enabled the "Hide..." function and it hid the fields that were empty and was not required, but those required and empty fields were not hidden. So that's the reason your empty fields are not being hidden.

    So, try setting up the fields as not Required and made a test, that will let the empty fields to be hidden.

    However I will be checking your form just if there is anything else that could be causing this issue.

    Please let us know if you need further assistance with this or open a new thread to make nonrelated questions.

    Thanks for using Jotform.