Submit button not working with Save and Return Feature

  • Profile Image
    ysuassessment
    Asked on October 03, 2013 at 11:42 AM

    Hi,

    We have a form that won't allow the user to submit if they are using the save and return feature. You can click on the Submit button at the end of the form, but nothing happens, and no data is submitted. We have replicated it on several browsers. If you complete the form without the save and return function, it's fine.

    We are scratching our heads, because we have two forms that do this and the other one is working fine!

    Here is the form that isn't working:

    Short PLAN registration form: http://www.jotformpro.com/ysuassessment/2013acadplan

    Long PLAN form (won't submit when using the save and return, i.e., "?session=email"): http://www.jotformpro.com/ysuassessment/2013acadplanmain

     

    This form is very similar, but DOES work with the save and return feature:

    Short REPORT registration form: http://www.jotformpro.com/ysuassessment/2013acadreport

    Long REPORT form (does work with the save and return feature, i.e., "?session=email"): http://www.jotformpro.com/ysuassessment/2013acadreportmain

     

    Thanks for your help.

     

    Hillary

  • Profile Image
    fivetownhoopdreams
    Answered on October 03, 2013 at 12:14 PM

    I got the ones to work for me in Chrome, may it is your cookie settings? Clear cache and try again.

  • Profile Image
    ysuassessment
    Answered on October 03, 2013 at 12:29 PM

    Hi, 

    I did clear my cache and it still didn't work. It does work as written above, but won't submit if you use the "?session=email" extension on the end of the long plan form.

    Thanks,

    Hillary

  • Profile Image
    Mike_T
    Answered on October 03, 2013 at 03:02 PM

    The issue is related to the Min Value validation on your Spinner fields. The session overrides default value to 0, so that the form can not be submitted with 'blank' (set to 0) Spinner fields.

    You can use one of the following solutions:

    1) Set the Min Value to 0 on your Spinner fields.

    2) Replace your Spinner fields with the Number fields. You can set the Default Value and Min Value for Number fields, and this will work fine with your sessions.

    Please give it a try and let us know if you need any further assistance.

  • Profile Image
    ysuassessment
    Answered on October 04, 2013 at 12:52 PM

    Yes, it worked! We didn't realize that was an option. Thank you very much!

     

    Best,

     

    Hillary