Jotform Tables: required fields are showing blank when they are not

  • Profile Image
    gcamfla
    Asked on December 08, 2020 at 07:14 AM

    Olá!

    Criei um meio de fazer com que os questionários não sejam enviados de forma duplicado e até o momento funcionou.

    Usei uma condicional para juntar um vetor resposta e criei um campo de texto oculto para receber o resultado deste vetor. Após isso, ativei nas configurações do formulário o recurso "Pergunta única" e direcionei o mesmo para o campo oculto criado.

    Deu certo porém, quando o usuário vai transmitir as novas submissões o campo "Respondente aceitou participar da pesquisa?" vem em branco. Esse campo é obrigatório e nunca deveria ser transmitido se estivesse em branco. Outro detalhe é que é impossível continuar o questionário sem esse campo preenchido. Pois, só a partir dele que os campos posteriores aparecerão.

    Poderia me ajudar nessa questão?

  • Profile Image
    Gustavo_H
    Answered on December 08, 2020 at 07:43 AM

    Bom dia, gcamfla.


    Posso ver que você se refere a este formulário, certo? Estava investigando as respostas do seu formulário em Jotform Tables e somente pude encontrar uma resposta em branco para esse campo no último mês, como você pode ver abaixo.

    1607431324_5fcf749c23fb3_

    Nesses casos pontuais de um campo requerido ser recebido em branco, se o usuário estava preenchendo em um navegador, pode ser que o usuário estava com o JavaScript desabilitado durante o preenchimento. Fiz um teste aqui tentando deixar a resposta do campo "Respondente aceitou participar da pesquisa?" em branco e não pude.

    1607431365_5fcf74c5d1d1c_


    Por último, se você está editando respostas recebidas no seu formulário, sempre é bom fazer uma segunda verificação para ver se todos os campos estão devidamente preenchidos.


    Se o problema persistir, por favor, entre em contato. Compartilhar o Submission ID pode nos ajudar a rastrear a resposta. Muito obrigado pela paciência e compreensão.


    Atenciosamente,

  • Profile Image
    gcamfla
    Answered on December 08, 2020 at 08:25 AM

    Olá Gustavo!

    Obrigado pela resposta.

    Porém, creio ser algo que está acontecendo na transmissão do formulário respondido para o servidor. Pois, quando alguém preenche o formulário e envia, o aplicativo Jotform envia tanto para o Google Sheets a nova submissão quanto o Jotform Tables. No Google aparece o campo preenchido mas no Tables não.

    Algo a frisar é que todos os pesquisadores fazem suas entrevistas via Jotform Mobile.

    Outro detalhe que destaco é que se eu baixar o jotform tables em .xlsx os campo vem preenchidos normalmente.

  • Profile Image
    Gustavo_H
    Answered on December 08, 2020 at 10:23 AM

    Olá, novamente, gcamfla.


    Muito obrigado pelas informações adicionais.

    Fiz um teste aqui, de acordo com o que você me disse, ao fazer o download da resposta em branco em Excel, posso ver que a o campo está preenchido.

    1607440859_5fcf99dbb4028_


    Muito obrigado pelas informações e por reportar esse erro, vou levar esse problema aos nossos programadores para que eles investiguem um pouco melhor o que pode estar acontencendo. Quando eles tiverem uma resposta, te atualizaram aqui neste chamado.


    Atenciosamante,

  • Profile Image
    Gustavo_H
    Answered on January 19, 2021 at 04:58 PM

    Olá, gcamfla.


    Recebemos uma resposta dos nossos programadores de que o erro foi resolvido. Você pode, por favor, nos confirmar se o problema já está completamente resolvido?

    Esperamos sua resposta.


    Atenciosamente, 😀✨

  • Profile Image
    gcamfla
    Answered on January 25, 2021 at 12:03 AM

    Olá Gustavo!

    Respondendo sua pergunta, até o momento não voltou o problema.

    Creio ter sido solucionado!

    Muito obrigado!

  • Profile Image
    Gustavo_H
    Answered on January 25, 2021 at 08:34 AM

    Muito obrigado pela confirmação.

    Vou atualizar os programadores sobre isso. Nos deixe saber por aqui caso esse problema volte a incomodar.

    Atenciosamente,