Iframe and Google Sites

  • Profile Image
    owenterprisepayroll
    Asked on October 07, 2013 at 12:20 PM

    We are having issues with forms that were embeded into our Google Site.  We have a secure google site that our internal employees access and we had some forms embedded.  The forms just stopped appearing on Friday.  I checked out the link itself (that was embeded in iframe) and it works outside of Google Sites.  I was able to get the form to appear if I embedded it using a secure form.  We do not need secure submissions, only the regular.  How do I embed this into the site without using the secure forms?

  • Profile Image
    Welvin
    Answered on October 07, 2013 at 01:32 PM

    Thanks for contacting us.

    Google Sites forced our form to use HTTPS even when you've embedded your form as HTTP since they run on HTTPS (Secure Environment). The solution is to put your non-SSL (HTTP) form to the Google Sites using 3rd party Embed Gadget. Please follow all steps below:

    1. Go to your site.

    2. Click on the page where the form is currently placed, click "Edit Page" button


    3. Open Insert Menu Select More gadgets at the bottom.


    4. Select Embed Gadget.


    5. Put your form iFrame embed code, adjust gadget width (by percent) and height (according to your form iFrame codes height value), then press OK.
    Let us know if you need any further assistance about this method.
    Thanks
  • Profile Image
    owenterprisepayroll
    Answered on October 07, 2013 at 01:34 PM

    I tried this, but still cannot get the form to come up.  It will only come up when in secure mode.  This just started happening on Friday.  We didn't do anything differently.  Everything was working properly prior to that.

     

    Chris

  • Profile Image
    Welvin
    Answered on October 07, 2013 at 02:03 PM

    Hi Chris,

    I guess this has to do with the recent changes made by Google. Unfortunately, I couldn't think of any possible solution about this rather than using the form secure embed URL.

    I'm searching for a solution around the web, but I couldn't see any. Let me search for more and get back to you if I'll find one. Unfortunately, I couldn't promise you more.

    Thanks