What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditions on e-mails

    Asked by jaures on October 08, 2013 at 06:00 AM

     

    Hi all,

     

    Plse, I set a form with 4 pages

    page1- Form Homepage where the customer choose the forms he want to fill (MAERS , COMAN or MAERSK&COMAN)

    page2- Template about MAERSK

    page3- Template about COMAN

    page4- Template about MAERSK & COMAN

     

    the conditions set on emails are:

    WHEN is

    * page2- Template about MAERSK   == send notification to ''bnninv1@maersk.com''

    * page3- Template about COMAN == send notification to ''loetitia.avohou@apmterminals.com;emerance.bocovo@apmterminals.com''

    * page4- Template about MAERSK & COMAN == send notification to ''bnninv1@maersk.com;loetitia.avohou@apmterminals.com;emerance.bocovo@apmterminals.com''

     

    ISSUES:

    1- some submission were not receives in mailbox specially when customer choose template on page 3 (COMAN). when I get in submission on my session on jotform.com i see them. but on the subsmission line i dont see the name of the company (COMAN) picture A.

    2- I understand  as the field [societe] appear blank, the condition on tthis field not work, by this way the notification dont reach the recipient.

    what can be the reason of this issue, can you help?

     

    best regards

    Screenshot
    E-mails Emails JotForm template session name
  • Profile Image
    JotForm Support

    Answered by EltonCris on October 08, 2013 at 07:10 AM

    Hi,

    1. Your condition is fine so the problem would be due to the fact that your "SOCIETE" field is not required. May I suggest to make that as "Required" in the form builder and retest your form. This might resolved the problem.

    2. This might be related to number 1 issue, if the SOCIETE field is blank, no conditions is met so therefore no email notifications will be fired up.

    I have also tested your form out and I am able to view the data on your form's submissions page.

    Hope this helps. 

    Regards!

  • Profile Image

    Answered by jaures on October 08, 2013 at 07:49 AM

    thanks a lot, will try it and revert.

     

    best regards

  • Profile Image

    Answered by jaures on October 09, 2013 at 07:16 AM
    still having the same issue
    plse help
  • Profile Image
    JotForm Support

    Answered by KadeJM on October 09, 2013 at 11:55 AM

    Hi jaures, I've taken another look at this issue for you to offer a second opinion about this matter. I think that the problem is the result of a conflict of some sort which is happening. According to your image and submissions history other then the name being listed which was blank. That was happening as my colleague mentioned for it not being required so it was being skipped by users beforehand. I also believe that the reason more information become available in other fields where this was skipped due to the fact that users whom were filling in your form were then clicking next to still get to them so that was why data was still showing partially for the submission that was related to those that had Societe as blank.

    One issue that we did find is that you're using the wrong separator when using Multiple Email Recipients. Your Notification lists a " ; " (semi-colon) when it should actually be a " , " (comma). Because of this that would break your Notification from being sent for those listed after the semi-colon which you had been using. 

     

    I ran a simple but small separate email test to check the use of emails and conditions with dropdowns being used in a similar way but I wasn't able to replicate the same problem. When I was testing your form I've realized that it seems to only be sending out " Notification 1 " for some reason. This was all I was getting on my end when I checked it via a clone to test it out more. 

    When you were previously using your form have you recently changed anything other than your Requirement for the " Societe " field as my colleague recommended? 

  • Profile Image

    Answered by jaures on October 09, 2013 at 12:28 PM
    yeah, when facing this issue
    i set a new condition as:
    if ''societe'' isblank send notification 1 and notification2
    in other hands, what is the exact solution to get rid of this issue?
    plse advise
    jaures
  • Profile Image
    JotForm Support

    Answered by ashwin_d on October 09, 2013 at 12:59 PM

    Hello jaures,

    Upon checking your form's condition, I found that the email addresses in your notification 2 still has the wrong separator. Please check the screenshot:

    The email addresses should be separated by comma (,) and not semi collon (;). This may be the reason you are not receiving emails from notification 2.

    Please add your email address separated by comma followed by a space and test your form again. Do get back to us if the issue persists.

    Thank you!