Form field missing and calculator not working

  • Profile Image
    Fearghal_Corbett
    Asked on December 15, 2020 at 02:30 PM

    Hi there,

    Hope you can help. I have created a multi-page form and have two problems on page 3:

    – something strange is happenning to the first two number fields. In the builder I have them as 'Mortgage' and 'Secured loan (other than your mortgage)'. But in the preview and on the embedded form, they are swapped around and a strange line appears above the first one. Screenshot attached.

    – at the bottom of the page I have added a Form Calculation widget that adds up all the fields on the page. However it's not working and doesn't show any calculation when you add numbers in the fields above. I did the same type of Form Calculation on page 2 of the form and this works okay.

    Many thanks for your help

  • Profile Image
    Gaetan_B
    Answered on December 15, 2020 at 05:52 PM

    Hello,


    A strange line appears above the first element

    I checked your form and it looks like you just need to delete the Divider there.

    1608072247_5fd93c37c64cd_

    But in the preview and on the embedded form, they are swapped around

    As you can see on the above screenshot, I don't see the fields swapped with each other, could you please check again?


    Regarding your last question:  at the bottom of the page I have added a Form Calculation widget that adds up all the fields on the page. However it's not working and doesn't show any calculation when you add numbers in the fields above. I did the same type of Form Calculation on page 2 of the form and this works okay.

    I have noticed a little typo in your calculation. Instead of starting with £ you start with the + sign. Correcting this should solve your issue.


    Hopefully this helps you!