Required field checking ...

  • Profile Image
    paul_mcdonald
    Asked on October 08, 2013 at 06:55 PM

    How do I get the nice error checking for required fields that is carried out in the PREVIEW Form function on your site?

    When I embed in my Wordpress site, error checking takes me to a different page, and doesn't highlight the fields on the page that need filling.

    Site: http://highfliers.ca/?page_id=1409

    Help please?

  • Profile Image
    EltonCris
    Answered on October 08, 2013 at 07:17 PM

    Hi,

    Your form isn't validating properly due to script conflicts. Re-embedding your form using iframe embed code should help resolved the problem. How to get your iFrame Embed Code

    Best Regards!

  • Profile Image
    paul_mcdonald
    Answered on October 09, 2013 at 06:19 AM

    Yes, iframe does allow for the form to be displayed, however, when I use IFRAME, the SUBMIT button at the bottom of the form is no longer there.

    It also disappears when using your PREVIEW function in your admin iframe embed tool.

    SAMPLE IFRAME: http://highfliers.ca/?page_id=1465&preview=true

    SAMPLE WORDPRESS EMBED of SAME FORM: http://highfliers.ca/?page_id=1409

     

  • Profile Image
    ashwin_d
    Answered on October 09, 2013 at 06:55 AM

    Hello Paul,

    Upon checking your webpage at  http://highfliers.ca/?page_id=1409, it appears to be display the form correctly including the submit button.

    I verified the behavior in chrome/IE/Mozilla and safari and in all the browsers I was able to view your form correctly. Please check this screenshot:

    It could be a temporary browser related issue. Have you tried clearing your browser cache already? Please clear your browser cache and see if that helps you. Here is a guide which should help you:  http://www.wikihow.com/Clear-Your-Browser's-Cache

    Do get back to us if the issue persists.

    Thank you!

  • Profile Image
    paul_mcdonald
    Answered on October 09, 2013 at 08:55 AM

    Ashwin, please see the response by your other support member who told me to use an IFRAME to fix my original problem.  You've attached a picture of the non iframe page.  Using the IFRAME may have fixed my original problem, but it introduces a much larger issue ... no SUBMIT button.

  • Profile Image
    paul_mcdonald
    Answered on October 09, 2013 at 08:58 AM

    I've solved the issue.  Removing the CAPTCHA has allowed my submit button to be viewed in the IFRAME page.