Submit won't work under certain conditions

  • Profile Image
    jenspepie
    Asked on October 10, 2013 at 08:41 AM

    Hi, in form 32732869372362 there is an condition (No. 4, {antrag}) that switches some form parts on/off. In case of option one (Neu-Mitglied) the form works fine. In case of option two (Bestehende Mitgliedschaft) I don't get a submission (nothing happens on click at submit (Senden)).

    Thanks for help!

    Regards
    Jens

  • Profile Image
    ashwin_d
    Answered on October 10, 2013 at 09:54 AM

    Hello Jens,

    Upon checking your form's condition, I found that when you select "Bestehende Mitgliedschaft" and proceed further to click submit button there are two required field unfilled.

    The two fields are : Beginn (Monat) and Beginn (Jahr).

    Can you please set the minimum value to these fields and see if that helps you?

    Thank you!

  • Profile Image
    jenspepie
    Answered on October 10, 2013 at 03:48 PM
    Hi ashwin_d, well I replaced this fields with other controls and successfully submitted the form. Thank you for help!Btw: is there a log or something else that records the processed steps and could be read in the back end or get as json or txt from your API? Would be very helpful to get rid of problems with more complex forms. Regards Jens
  • Profile Image
    Mike_T
    Answered on October 10, 2013 at 05:24 PM

    I am sorry, but I do not think that we log these js validations on the server side, so that we do not have that data provided with our API.