Keap Integration: Billing Address on Keap isn't getting any data from the Address field

  • Profile Image
    EltonCris
    Asked on December 21, 2020 at 09:42 PM

    I've been troubleshooting Keap issues on this ticket https://www.jotform.com/answers/2776091 and can confirm that the following doesn't work.

    When you map the "BillingInformation" from Keap, to an Address field at Jotform, there's no data sent to Keap.

    12222020_jGzv6HX7pG.png

    12222020_gYbxZF1nqR.png

    FYI, there's no "Billing Address" field on the integration's field list, it only shows "BillingInformation" which I assume the billing address field on Keap.

    Test form: https://form.jotform.com/203557665551057

  • Profile Image
    serbay
    Answered on December 28, 2020 at 05:58 AM

    Hello @EltonCris,


    We have checked the related issue.


    The related InfusionSoft Keap integration has been working successfully with all its features.

    We figured out that the issue due to incorrect mapping. The address space in the user form must be mapped separately for each InfusionSoft sub address fields. If mapped as shared below, the "Billing Address" information is transferred correctly.

    1609152413_5fe9b79dc02de_Screen Shot 202

    **Screen shot has been taken on the user clone form.


    After submission,

    1609152893_5fe9b97da2b94_Screen Shot 202


    Please check your integration and test with new submission.

    If this issue fixed, please update user.

    Thanks.


  • Profile Image
    EltonCris
    Answered on December 28, 2020 at 05:08 PM

    Thanks, Serbay. It works!

    12292020_14CsPDcPyV.png

    Didn't know that and I didn't try it because it's not the usual thing, maybe if they both appear subfield to subfield on the list, I would. :)

    I'll inform the user.