What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    JoForm embeded Code is cut off on my website, I use Zenfolio.

    Asked by Brauliohdez on October 15, 2013 at 06:06 PM

    I try to insert Jotform in my website (Zenfolio web developer) but the form cut off, I am not sure if the problem is Zenfolio, any help is appreciated.

    Screenshot
    JotForm problem
  • Profile Image

    Answered by jedcadorna on October 15, 2013 at 06:30 PM

    Good day,

    Thank you for contacting us. May we request for the site URL so that we can further check on what's causing the issue. By the way are you trying to view it using a browser or a mobile device?

     

    Thanks,

  • Profile Image

    Answered by Brauliohdez on October 15, 2013 at 10:48 PM

    I have changed the browser, from Fire Fox to Chrome and then to Safari, and always the same thing, I have contacted Zenfolio but they said they don't look at any embed code from third party, so I don't know what to do, the link is: http://www.braulyphotography.com/order.

    Any help is really appreciated.

    Thanks.

  • Profile Image
    JotForm Support

    Answered by EltonCris on October 15, 2013 at 10:58 PM

    Hi,

    Try to re-embed your form using iframe embed code. See if this helps: How to get your iFrame Embed Code.

    Another solution is to add a style tag on ctl03_RichText_ctl00 element ID with a width of 800px if you can view its source code. It would look like this:

    <span class="zb-embed" id="ctl03_RichText_ctl00" style="width: 800px;">

    Thanks!

  • Profile Image

    Answered by Brauliohdez on October 16, 2013 at 05:58 AM

    Your are so good, you solved my problem,

    Thanks a million times.

  • Profile Image
    JotForm Support

    Answered by EltonCris on October 16, 2013 at 06:00 AM

    You're welcome buddy!

    Cheers! =)

  • Profile Image

    Answered by Brauliohdez on October 16, 2013 at 06:56 AM

    Hi Elton,

    Please, there is something I would like to be clarified, if I specified width 800 in the style form before generate the embed code (something that I was doing since the beginning), save and run, then in the iFrame show width: 100%, Why not the Jotform update to the right number in the first place? It means that I have to fix the width in the iFrame every time I update my forms?

    Please help.

    Thanks in advance.

  • Profile Image

    Answered by Brauliohdez on October 16, 2013 at 07:13 AM

    Hi Elton,

    On the Form Style I put Form Width: 800; but always the code generated show style="width:100%, Why this happend?  Below is the code:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//form.jotform.co/form/32873389896881" frameborder="0" style="width:100%; height:1735px; border:none;" scrolling="no"></iframe>

  • Profile Image

    Answered by jedcadorna on October 16, 2013 at 07:25 AM

    @Brauliohdez,

    CSS styling is just an additional styling for your forms and doesn't really affect the internal code generated by the system. 

  • Profile Image

    Answered by Brauliohdez on October 16, 2013 at 08:44 AM

    I think this doesn't answer my concern.

  • Profile Image
    JotForm Support

    Answered by guilledutra on October 16, 2013 at 09:29 AM

    Hi,

    the width="%100 refers to use the whole width of the form 800px in your case as the width of the iframe.

    Thanks

     

  • Profile Image

    Answered by commonwheel on October 21, 2013 at 12:43 PM

    Zenfolio was doing the same thing for me.  I was using the Embed function to put in the Iframe code. To fix this, I just pasted the iframe code in as html without using the embed function.  Works perfectly!

  • Profile Image

    Answered by gwenisner on March 31, 2015 at 01:28 PM

    i had problems with this too and jot form hasn't gotten back to me. so after reading this 

    i used iframe and copied in as html and it is now working. thanks everyone!!!

  • Profile Image

    Answered by Carina on March 31, 2015 at 01:57 PM

    @gwenisner 

    Depending on the support request's number the support is not immediate but we still have a good response time. 

    I'm glad that everything is working now. If you need further support please let us know on a separate thread or by updating the ones already created by you.

  • Profile Image

    Answered by gwenisner on March 31, 2015 at 01:59 PM

    yes - i am very happy with jotform's response time - just an not patient i guess

  • Profile Image

    Answered by Carina on March 31, 2015 at 02:02 PM

    We do our best to provide a reply on a timely manner, but our forum is also made in a way that is like a data base for other users to search solutions for their problems, so it's good to know that you still got a solution from us.

    If you need further assistance please let us know as we're here to help.