What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form content not clearing

    Asked by paulalexanderbreen on October 21, 2013 at 12:25 PM

    Hi All

     

    I have a problem with a form not clearing after submission.

     

    It's not a cache problem. 

     

    Basically everything works fine, emails are sent, thank you message appears as it should, but the form isnt clearing at all. Now I've had people try it for me on all sorts of devices and everyone has the same problem.

     

    FYI i have another Jot form on the same testing site on a differrent page and that works fine. 

     

    The problem started when i removed the captcha field (I did this at the suggestion of JotForm as it was causing problems with Google Spread Sheets)

    Any suggestions please??

    BTW I have found the support guys at Jot Form extremly helpful, they suggested that i post this problem for everyone to see.

    One last thing which may or may not help, I think it may be something to do with a security issue. As I said above i have two forms being tested on the same site. When I open the page with the other form that is working, I noticed that there is no mention of security. When I open the page with the problem everything seems to flicker at the bottom of the screen and it mentions secuity.

     

    Regards

     

    Paul

     

     

    content Emails JotForm Thank You message problem style
  • Profile Image

    Answered by paulalexanderbreen on October 21, 2013 at 01:08 PM

    Hi All

     

    i think i know what the problem is, just dont know how to cure it.

     

    I have the form embedded on the web site with I Frame. I had a look at the the I Frame with the viewer and it shows the form completed with the same details as everyone sees when they go to the form after their first entry. Therefore i assume that its a problem with the creation of the I Frame

     

    Any suggestions?

     

    Regards

     

    Paul

  • Profile Image
    JotForm Support

    Answered by guilledutra on October 21, 2013 at 02:31 PM

    Hi,

    could you please check your form Autofill Options, disable the Autofill option following the next steps:

    1. Select "Setup & Embed"

    2. Click on "Preferences" icon.

    3. Click on "Advanced Settings"

    4. Click on "Edit Auto Fill Settings"

    5. Disable the "Autofill" option

    Hope it helps

    please let us know if you need further assistance

    Thanks

  • Profile Image

    Answered by paulalexanderbreen on October 21, 2013 at 02:47 PM

    Hi Guys

     

    worked a treat!! 

     

    I guessed it was something in the settings

     

    cheers

     

    Paul

  • Profile Image
    JotForm Support

    Answered by guilledutra on October 21, 2013 at 02:54 PM

    Good to know that it is working now,

    please let us know if you need further assistance

    Thanks

  • Profile Image

    Answered by EliezerN on October 21, 2013 at 04:30 PM

    @Paul

    Your last reply came out empty for some reason. Please resend it using this link at this time: http://www.jotform.com/answers/281629-Form-content-not-clearing#5

    However, if your comments or question is about a different topic, we would appreciate if you open a new thread to post your questions.

    Thanks

  • Profile Image

    Answered by paulalexanderbreen on October 21, 2013 at 04:39 PM
    Hi

    The fix you gave me about the job not clearing worked great thanks

    Cheers

    Paul