What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My form is not displaying correctly on some browsers and not at all on iPhones

    Asked by elle_steiner on October 23, 2013 at 11:52 AM

    The JotForm is not loading on iPhone for this page: http://give.brighamandwomens.org/preview/pages/email-survey

    Also, in IE and Firefox on a PC the 2 column layout of the checkboxes isn't displaying correctly, it's bumping the second column under the first column and indenting the first column. It looks correct in Safari on a Mac, but we need it to look correct on all browsers and on mobile devices

    Page URL:
    http://give.brighamandwomens.org/preview/pages/email-survey

    some browsers survey JotForm checkboxes email
  • Profile Image
    JotForm Support

    Answered by ardy0689 on October 23, 2013 at 12:22 PM

    Hello, unfortunately I can not replicate the bumping in the 1st and second columns from IE9, FireFox and iPhone 5.

    Firefox:

     

    IE9:

     

    iPhone 5 under iOS6.0

     

    I have tried Firefox 10,17,22 to 25 versions and IE7-IE9 versions but could not replicate the issue in your form in your webpage.

    Normally, JotForms are responsive and highly optimized for mobile compatibility. I have cleared your form's caches from our system. Please let us know if this problem persists. Thanks

  • Profile Image
    JotForm Support

    Answered by ardy0689 on October 23, 2013 at 12:23 PM

    In addition to my post, you could try cloning your form and re-embed using the Iframe embed method.

    Please let us know if the above suggestions have fixed your problem. Thanks