What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    I have been trying to create a form but it will not let me save what I have worked on, how do I get past this?

    Asked by campfoster on October 24, 2013 at 12:51 PM

    I have tried for two days to get a staff application put together via JotForm. I have been a past JotForm user and love using it, but this issues has me perplexed. I have not been able to save anything that I have worked on. The autosave feature seems to be working overtime but not actually saving anything -- the save icon spins and spins, but when you try to reload the page as it seems to have frozen in that status nothing saves.

    Please help -- I would like to not move to another form creator, but this issue is beyond frustrating.

     

    Thank you.

    Screenshot
    create a form create form creator JotForm status icon
  • Profile Image
    JotForm Support

    Answered by ardy0689 on October 24, 2013 at 01:30 PM

    We apologize for any inconvenience that this might give.

    I have cleared your form caches from our system. This may help sometimes.

    You could also try the following in your end:

    1. Flush your DNS caches. Please see this useful guide for flushing DNS on different operating systems

    2. Clear your browser's caches and sign back in and please try if it fixes it.

    3. Reset or Power Cycle your router. You need to unplug the power cable of your router for 30 seconds and replug to conduct a power cycle or just reset your router.

    4. Complication on your ISP DNS implementation or issues behind an intranet network may sometimes cause issues like this. You could try using a free proxy client like Ultrasurf.us. You can go to Jotform and do your form work while connected to their proxy server.

     

    Please let us know if the above suggestions have not fixed your problem. Thanks