What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Multiple Notifications: Data sent to emails are not correct

    Asked by andypenn on October 24, 2013 at 04:22 PM

    six surveyors my 1st in my list (chris hunt ins) sends out how I want it to  the rest do not I cant see where the problem lies  I have been through compose email and I cant see anything different to the one that works , the only thing that I have noticed is that the time and date field under the 1st dear chris hunt in the form fields says {time} where as others have a number included next to the word.

    what do I need to do to correct this

    Page URL:
    http://form.jotform.co/form/32911873412856

    date field email problem next
  • Profile Image
    JotForm Support

    Answered by ardy0689 on October 24, 2013 at 04:53 PM

    Hello, that is because you have different date & time fields that you placed in your form. They are the same but each one has different IDs. All your fields have different IDs even if they look the same.

    See this illustration, to further explain on why all of your notifications are not working except Chris Hunt de-emp notification. Here is why:

     

    As you can see from the above image, the ID toolbox correctly follows the sequence of your form. They are group in batches which is the same with your form alignment. However, the main problem is that the IDs do not match. Each of your notification template uses only the IDs of "Chris Hunt de-emp" fields. It does not work as it is hidden when you choose others and not submitting at all.

    Please correct them on each notification template and please do not forget to double check if the IDs are truly theirs. Thank you

  • Profile Image

    Answered by andypenn on October 24, 2013 at 06:23 PM

    there is no way that I will be able to sort this out, because last week an issue was raised to 2nd level as you were unable to recitfiy a fault  I found my own way around this I was informed that 2nd level would contact me back via this type of response, as this has not happened as yet and doubt if it ever will basically you have been wasting my time for a week

    Answered by Cesar

     

    Hello, I've gone ahead and replicated the error on your form. The conditional rules seem to be correct, nevertheless the first 2 choices fail to appear. At this moment I will create a ticket to escalate your issue to the next level support. Once they have an update on the matter, they should let you know over this thread. Thank you.

    So what do I do now the fields and coresponding numbers are all over the shot feilds were copied and pasted . I have 42 fields the combinations are endless and you think that one silly picture is going to sort this mess out seeing nobody has has bothered contacting me back and i have been requesting help that various people have been giving instead of helping it has actully confused the issue even more, due to this fact can somebody recrate this form and deliver it back to me working,  I cant express how --- I am  Is this the level of customer care that I have to expect. I have 25 replies  from support and not one of them has managed to get this form working. this form was supposed to be working saturday last week the subjects speak for themselves surveyors waiting for clients on an advert that has already been deliverd to peoples homes , link on our website to the url that also keeps changing.

  • Profile Image

    Answered by Cesar on October 24, 2013 at 07:35 PM

    Hello andypenn, 

    In regards to the ticket originally posted on http://www.jotform.com/answers/280908-Conditional-Rule-Confusion#14 this ticket was in regards to the conditional rules that were not working on your previous form.

    In regards to your current issue, I can help you setup the conditional fields to the proper email alert. Do keep in my mind this may take some time to setup. I will go ahead an update you through this thread once the fields are in the proper email alert. Thank you.

  • Profile Image

    Answered by Cesar on October 24, 2013 at 07:59 PM

    Hello, the I've gone ahead and chenged the fields to their respective surveyor. Kiondly test the form out. do let us know if they now work properly, thank you.

  • Profile Image

    Answered by andypenn on October 25, 2013 at 05:31 AM

    Cesar thanks, but just for the record the reason for the form becoming so jumbled is that 2nd level did not come back to me and I had to find away round this for myself copying fields,  I not supprised its in a mess, I still feel this could have been avoided if I had been replied to by 2nd level..

    However the form does now  send the correct info, two small issues on (marriott ins) the subject is all in lower case where as all the other surveyors names have an upper case 1st letter. and on (chris hunt ins) the mail layout I recieve is jumbled (I think that chris hunt ins is set to a single coloum where ther rest are set to two ).  

    And you may say that I have to fire off a new thread but is there a way that on the thankyou page an  option to return to form or leave can be applied (as at present you have to reload the form completley rather that using the backspace of the browser,to return to the form  so each client will need to do this twice, ( for your advice should you browser backspace the text disapears from the text field and the form if sent comes through blank).

    once again thanks

  • Profile Image
    JotForm Support

    Answered by EltonCris on October 25, 2013 at 06:45 AM

    @ andypenn

    The minor issues can be corrected on your form notifications. (Setup & Embed > Email Alerts). If you need further assistance about this, let us know.

    Yes, you can use thank you message and add the links from where the form is embedded or the form URL itself so when the user clicked it, they'd be redirected back to the form page.

    Yes, we always recommend opening a new thread for each of your questions next time like what we have told you before. We just can't handle multiple questions in a thread, it might confused other supports and it would be hard to track the on going topic being discussed on a single thread.

    Thank you for your understanding.