Send form responses to the Power Automate

  • Profile Image
    denboice
    Asked on February 01, 2021 at 03:22 PM

    I am attempting to create a flow using power automate to add a line to a SQL database when a form is completed. So far, I am unable to make the trigger fire. Please help.

  • Profile Image
    roneet
    Answered on February 01, 2021 at 09:11 PM

    Please check this video to insert Form responses into the database:

    Are you getting the form responses?

    Have you checked the SQL database credentials? Are you able to authenticate the SQL database?

    Let us know how it goes.

    Thanks.

  • Profile Image
    denboice
    Answered on February 02, 2021 at 08:06 AM

    Thank you for your response. To answer your question, SQL server is fully authenticated and working in production on several flows. The problem I am having is that Jotform never triggers the flow when a survey is completed. The survey has been completed multiple times, and this is the correct survey. As you can see from the flow status page, the flow has no run history. The tigger just doesn't fire from JotForm.1612271150_60194e2ee44d6_

  • Profile Image
    Zahra_S
    Answered on February 02, 2021 at 09:24 AM

    Hi there!

    Can you please share the form link that you have connected with your Microsoft Flow? We would like to test the form on our end and find the issue.

    We are looking forward to your response.

  • Profile Image
    denboice
    Answered on February 02, 2021 at 09:26 AM

    Thank you for your reply. The link to the form connected to the flow is: https://form.jotform.com/203424645315046

    Thank you again for your quick replies. :)

  • Profile Image
    roneet
    Answered on February 02, 2021 at 10:44 AM

    May you please kindly check with the flow checker tool on Microsoft Flow and see if there are errors showing up? 

    Here's a link with details about how to use it: https://docs.microsoft.com/en-us/business-applications-release-notes/october18/microsoft-flow/flow-checker

    It would help if you could provide a screenshot of the errors, the flow you're trying to achieve.

    Thanks