What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Items in form 'selected by default' are displaying incorrectly!

    Asked by ZeitgeistMastering on November 06, 2013 at 04:03 AM

    Here is the form:

    http://zeitgeistmastering.com/order.html

    I have set it up (to my knowledge) the way it should be yet it still does not function correctly...

    The form in it's default setting shows every prodcut except 1 selected by default.

    However, The settings have only one item with the "Selected by default" checkbox ticked (see attached picture)

     

    So, question:

    1.  Why does the Item that has this checkbox ticked not display as the only one selected?

    Is this a bug?

    Page URL:
    http://zeitgeistmastering.com/order.html

    Screenshot
  • Profile Image

    Answered by pinoytech on November 06, 2013 at 05:54 AM

    Hi,

    Sorry for the inconvenience that may have caused. I've check your website where your form is embedded, I was able to reproduce the issue and it seems "Track Mastering (Full Hardware use - includes revisions)" is the only item selected. Because of that, I've clone your form for further investigation and found out that the issue is had something to do with your condition.

    Disabling/removing this condition in your form, should fixed the issue. You might like to take a look at this clone form: http://www.jotformpro.com/form/33092223245951

    For more information, please take a look at this video: http://www.screencast.com/t/GDh35UMzyQ3

    If you need further assistance, please let us know.

    Thank you!

  • Profile Image

    Answered by ZeitgeistMastering on November 06, 2013 at 06:50 AM

    Thanks very much for this...  I agree that it works if I remove this condition and this is a good start...

    But of course I want this condition in there...

    I only want the field 'DDP or Redbook fileset required' to display if the item quantity selected is greater than 8.

    Why can't I do this ?  It clearly is a bug or is there another way of achieving this that you can think of?

  • Profile Image

    Answered by pinoytech on November 06, 2013 at 07:45 AM

    Further investigation with regards on the issue, I confirm that this is a bug as I've reproduce the issue on my end using the clone form. I will now forward this issue to our dev team for further investigation and for further assistance.

    Again, our sincere apologies for further inconvenience that may have caused.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 07, 2013 at 09:57 AM

    This bug has been fixed. Kindly test it and let us know if you still encounter any problems.

    Cheers!

  • Profile Image

    Answered by ZeitgeistMastering on November 07, 2013 at 06:21 PM

    HI there,

    I've tried everything numerous times... sorry... still does not work for me...  still bugged... 

    Everytime I add a condition, relating to the track pricing / paypal field, I get issues.

    What I want is simple:  I want a field to be hidden unless the quantity of an order goes above a certain amount (in this case 8)

    The field I want hidden is "DDP or Redbook fileset required?"

    This should be hidden by default and show if any of the order selections have a quantity of 8 or above.

    more help would be greatly appreciated ... i'm about to give up!

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 07, 2013 at 06:46 PM

    Sorry, I have fixed this yesterday but the fix affected the overall performance of the conditional logic system, so I reverted the changes temporarily.

    I will find another solution and send you an update you soon.

  • Profile Image

    Answered by ZeitgeistMastering on November 08, 2013 at 03:11 AM

    Oh, that's not very cool...  I spent ages trying to figure out why it stopped working!  A quick message would have been nice!

    I look forward to this bug being fixed soon.

    Thank-you

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 09, 2013 at 12:06 AM

    Fixed. Let me know if there are any other issues.

    Best regards!

  • Profile Image

    Answered by ZeitgeistMastering on November 12, 2013 at 02:40 PM

    Seriously - did you test the form?  Still does not work correctly for me - now all fields are selected by default when only 1 field / item should be!  For me, this is worse than before.

    So it still needs work and now I am geting pretty sick of wasting my time on Jotform! 

  • Profile Image
    JotForm Support

    Answered by Mike_T on November 12, 2013 at 03:14 PM

    Can you please clear your browser cache and check it again? The form is showing only one selected item from my side.

    If this issue is happening when you add some more conditions, please let us know.

  • Profile Image

    Answered by ZeitgeistMastering on November 13, 2013 at 09:55 AM

    Yes I currently have the condition disabled / removed again as it was not working...  also not from the Jotform preview!  As soon as I add the condition again, there is a problem where all items show as being selected.

    If you add the condition that is shown above that I removed, you will most definitely see the problem still exists...  The condition works but all items are selected when they should not be...

  • Profile Image

    Answered by EliezerN on November 13, 2013 at 12:41 PM

    Thanks for informing us bout the continuity of the issue.

    I cloned your form and I was able to find that the issue has not disappeared yet. If the condition to Show the field "DDP or Redbook fileset required?" is enabled all the product items are selected by default: 

    So, this message has been forwarded to our colleague Neil so that he can check this issue and provide a possible solution.

    Thanks for your comprehension.

  • Profile Image

    Answered by ZeitgeistMastering on November 13, 2013 at 02:17 PM

    The issue has been the same all along and yes still exists... Please do not contact me again until the problem has been fixed & tested. I would have thought Testing was a standard procedure when debugging something. It is really frustrating being told that it is fixed all the time when it clearly is not.  It's really not professional.

    Thanks

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 13, 2013 at 03:01 PM

    @ZeitgeistMastering

    You are correct, testing is a standard procedure. I actually tested your form the first time, recreated the problem on a test form (under my account) and found out that the quantity conditions are causing the problem, so I went ahead and fixed it.

    Little did I know that 'special pricing' can also produce the problem, a factor that was present on your form and was missing on my test form, hence the blunder.

    With that said, I would like to offer my personal apology for all the inconveniences I have caused. Also, I would like to inform you that the problem is now fixed.

    Have a great day.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 13, 2013 at 03:02 PM

    By the way, kindly clear your browser cache if the errors persist.

  • Profile Image

    Answered by ZeitgeistMastering on November 15, 2013 at 09:56 AM

    ...

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 15, 2013 at 10:17 AM

    Here's an old clone of your form with all the conditions enabled:

    http://www.jotformpro.com/form/33183768116963

     

    Here's the new clone with all the added conditions enabled:

    http://form.jotformpro.com/form/33184247820958?

     

    As you can see from my screenshots, the problem described has already been resolved. I have tried to reproduce the problem but to no avail.

    Does the problem persist on your end at your form's current state?

    Have you tried using a different browser to see if the issue is browser specific?

  • Profile Image

    Answered by ZeitgeistMastering on November 15, 2013 at 11:19 AM

    Now I feel like a loudmouth fool... sorry for the outbirst...  Was just frustrated (perhaps my ISP cache had not refreshed or something) It seems to be working as desired now - many thanks!  got there in the end... case closed I think... :)

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 16, 2013 at 01:46 AM

    No worries. As a member of the customer service team, I do understand where you are coming from.

    Please do not hesitate to contact us again should you require assistance in the future.

    Cheers!