What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Cannot Submit Form Via Internet Explorer 9

    Asked by tricia_azco on November 08, 2013 at 04:15 PM

    I have users trying to submit via IE - they cannot hit the 'next' button and advance the form.

     

    I have tested on IE 9.0.8112.16421 and replicate the issue everytime. However, Chrome and Firefox work great...

     

    Page URL:
    https://sites.google.com/site/azcoprequal/home/azco-prequalification-f<br/>orm-1

    next next button
  • Profile Image
    JotForm Support

    Answered by Mike_T on November 08, 2013 at 05:14 PM

    Thank you for creating this separate thread.

    I have tested your page using IE 10 on my Windows 7, and IE 9 through browserstack.com, but I was not able to replicate the issue. The Next button worked fine for me.

    Is this issue happening when you check the form by direct form URL via IE 9?

    http://www.jotform.us/form/32386240934152

    Also, you can try to use a form iFrame code instead of the standard Embed code on your Google Site.

    We are looking forward to hearing from you.

  • Profile Image

    Answered by tricia_azco on November 11, 2013 at 04:17 PM

    It look like it works fine when the direct link is given.

  • Profile Image

    Answered by Cesar on November 11, 2013 at 04:47 PM

    If it workd on the direct link most likely our form may be experiencing some sort of conflict with another element on you webpage. Do try to re-embed your site using the iFrame Method and check if the issue persists then. 

    I have also tested the form embedded on your webapage (tested it on IE9 Win7 BrowserStack) and the next button works fine.

    https://cms.jotform.com/uploads/image_upload/image_upload/global/20775_bs-ie9001.png

     

    Do let us know if the issue persists. Thank you.

     

    Related Article:

    Getting-the-Form-iFrame-Code