Data lost/cleared when filling out form

  • Profile Image
    gaceweb
    Asked on November 10, 2013 at 01:41 PM

    Hi there

    I just build a form (my first with some condition, show/hide fields), but when start filling with data, the form resets and all the entered data is lost. 

    Can anyone, please give some hints in how to solve this problem. The page is in portugues, but I hope you can enter all the necessary information to see where the problem may reside.

    I have added the url to the page in reference

     

    Thanks and regards

    AC

  • Profile Image
    Cesar
    Answered on November 10, 2013 at 01:57 PM

    I've tried to perform a submission on your form. It seems you have an auto-refresh code on the webpage, making the site reload exactly every 30 seconds:

    https://cms.jotform.com/uploads/image_upload/image_upload/global/20710_autorefresh30.png

    I would suggest to remove this code form this specifc page, unless you absolutely need it, then I would suggest to use a value much higher than 30 seconds. To allow people enough time to fill out the form. Thank you.

  • Profile Image
    gaceweb
    Answered on November 10, 2013 at 04:25 PM

    Works fine. Removed the meta tag that was refreshing the page every 30 seconds.

    Thanks for the support.

    AC

  • Profile Image
    jonathan
    Answered on November 10, 2013 at 04:30 PM

    @ gaceweb

    Hi,

    We're glad to know that our colleague Cesar suggestion works.

    Contact us again anytime should you have other inquiry.

    Thanks.