Dropdown: conditions are not working

  • Profile Image
    nomanaziz90
    Asked on February 14, 2021 at 10:31 PM

    https://www.screencast.com/t/MzlM9JZ9Suh


    Review video in above link. My form Name Trax Medical Insurance has a dropdown named Marital status in which when I select married it show new tab name how many spouses do you have then I am selecting 2 it showing the relevant details. as soon as I am reverting marital status dropdown back to single without touching anything fields that are not relevant to single are appearing which needs to be reverted as I have changed the option from the dropdown.

  • Profile Image
    Sam_G
    Answered on February 15, 2021 at 04:09 AM

    Hi Nomanaziz90,

    Thank you for contacting Support.

    I have cloned and tested your form.

    Upon checking, your conditions are set to Show even if the fields are not hidden.

    This will create a conflict on the field's behavior; if the field is hidden by default, it should only be associated with a show condition. Then if a field is shown by default, it should only be associated with a hide condition.

    Here's my cloned form: https://form.jotform.com/210451756953964

    Kindly check and let us know if you need further assistance.



  • Profile Image
    nomanaziz90
    Answered on February 15, 2021 at 05:49 AM

    Yes I know its conditions that works this way and your clone is working the same way.

    I want you to fix it, either it is required to make changes in the condition or there is bug. In case it is required to change conditions do change on clone form.

    As conditions are working while I am moving forward from start to end while changing marital status extra or not required fields should have been closed in any case.

  • Profile Image
    ashwin_d
    Answered on February 15, 2021 at 06:31 AM

    This is not a bug, but it is caused because when you select the other field value and then go back to the previous question and change its value, the other field value is not cleared automatically. You can edit your condition to fix this issue but the easiest option to fix this issue is by changing the form setting "Clear Hidden Field Values" to "Clear on Being Hidden". Please check the screenshot below:

    1613388633_602a5b59af181_clearHidden.gif

    Please change your form's setting and that should solve your problem.

    Hope this helps.

    Do get back to us if you have any questions.