Issues with mobile devices like phones/tablets not saving data to Jotform

  • Profile Image
    Michael Sugg 
    Asked on February 15, 2021 at 12:59 PM

    We have a Jotform that was built by Platinum for us to take in patient information. We've been experiencing problems where patients say they completed the form and submitted, but the data does not exist. Platinum informed us that there is a known issue where submissions from mobile devices do not always work--yet there is no warning or error.

    What is being done to solve and fix this?


    Here is the link to the form:

    You can access the online paperwork by clicking here:  https://form.jotform.com/202674433615050??patientId=AAJKL&clinicName=Covington%20Family%20Chiropractic


    Platinum says this is an issue that Jotform needs to resolve this.

    What can be done to fix this?

  • Profile Image
    Cecile_A
    Answered on February 15, 2021 at 04:30 PM

    Hello there,

    Kindly allow me some time to conduct some tests.

    I'll get back to you shortly.

    Thank you.

  • Profile Image
    Cecile_A
    Answered on February 15, 2021 at 04:57 PM

    Thank you for waiting.

    I cloned form 202674433615050 to test. Then, I sent a test submission to it using the mobile app and the submission was saved successfully and can be viewed via Jotform Tables.

    Guide: How-to-view-form-submissions

    I also sent a test submission to the form using the browser of my mobile phone but I was still not able to replicate the issue.

    As per checking, you have one email notification and one autoresponder. Are the complaining patients able to receive the autoresponder email? Or are you able to receive the email notification after their submission?

    1613425983_602aed3fd7f3e_16.png

    Looking forward to your reply.

  • Profile Image
    Michael Sugg 
    Answered on February 15, 2021 at 05:55 PM
    So a husband and wife both received an email asking them to fill out the form—each with a unique patientID parameter.

    Both used an iPhone.

    The wife’s actually saved and she received an email saying the form went through.
    The husband received a blank screen and no email—which indicates it didn’t go through.

    We can’t figure out what would cause this to work some times and not all the time.
    Mike

    ...
  • Profile Image
    Cecile_A
    Answered on February 15, 2021 at 07:20 PM

    I checked your form's settings to see if you have enabled Unique Submission or Unique Question which might disable submissions coming from the same IP address but it's not enabled. Thus, user can send submissions from the same device and from the same IP address.

    1613434352_602b0df0bcefa_23.png

    Upon form submission, are there any errors displayed? I can't still replicate the issue using iPhone opened via Safari.

    I have cleared your form cache. If the issue persists, kindly let us know.

    For now, since your form is quite long, I suggest you to enable Continue Forms Later so that your users can save filled data and continue filling the form in their chosen time.

    1613434704_602b0f50675c7_24.png

    Should you have further inquiries, kindly let us know.

    Thank you.

  • Profile Image
    Michael Sugg 
    Answered on February 16, 2021 at 09:33 AM
    Ok I will ask Platinum to enable to the Continue Forms Later option.
    When it fails they don’t seem to get an error—just a blank screen. We will continue to test to see what happens.
    Mike

    ...
  • Profile Image
    Sam_G
    Answered on February 16, 2021 at 10:17 AM

    Hi Mike,

    If the issue happens again, may we ask for a screenshot: https://www.jotform.com/help/438-how-to-post-screenshots-to-our-support-forum

    Kindy get the console logs error as well.

    https://www.jotform.com/help/453-how-to-get-a-console-report-from-most-common-browsers

    Thank you.