HIPAA: When you sort the column with blank cells, those rows with blank cells under the sorted column goes hidden

  • Profile Image
    Richard_Krouch
    Asked on February 23, 2021 at 02:09 PM

    I just filled out our Request Appointment form for a patient "Tina Doyle" and it is not showing up in the table.


    I received the correct Thank You page and I received the Notification Email but when I go to the table her submission is not there?


    See attached


  • Profile Image
    EltonCris
    Answered on February 23, 2021 at 03:36 PM

    We are truly sorry about that. We had a data replication issue between our servers recently but it should be fixed now. You should now be able to see your form submissions data. Thanks!

  • Profile Image
    Richard_Krouch
    Answered on February 23, 2021 at 08:03 PM

    Hi EltonCris,

    Nope, still cannot see the submission. I wrote 3 other questions relative to this same issue before I found this forum. I put the same title on each one.

    Rich

  • Profile Image
    EltonCris
    Answered on February 23, 2021 at 10:02 PM

    We are truly sorry about that. I have escalated this problem to our back-end team for further investigation. We will inform you here once this is fixed.

  • Profile Image
    Richard_Krouch
    Answered on February 26, 2021 at 12:57 PM

    Two more patients records went missing. They entered their data this morning and the information was in the table, then 10 minutes later the records were gone. The Appointment requests that just went missing are for Lorraine Walsh and William Walsh. Here is the link to the table https://hipaa.jotform.com/tables/2103273683900511614362230_6039367616da4_MoreMissing.JPG

  • Profile Image
    Richard_Krouch
    Answered on February 26, 2021 at 01:46 PM

    A little more information for the developer.

    1. If I click on the folder the missing records will show up individually
    2. This record does not show up in the table but will display if I step through the submissions.

    1614365178_603941fa0b9c6_MoreInformation

  • Profile Image
    Richard_Krouch
    Answered on February 26, 2021 at 02:44 PM

    I think I figured it out. Request Appointment table and Process Status table are linked. If there is no Process Status in the Process Status field on the Request Appointment table then the record does not show. I tested by deleting the Process Status and refreshing the page.

  • Profile Image
    EltonCris
    Answered on February 26, 2021 at 03:59 PM

    Thank you and I'm glad that you figured that out. We really can't access your Tables due to HIPAA restrictions so we can only test on our HIPAA account with different setup. I assume that it's all good now?

  • Profile Image
    Richard_Krouch
    Answered on February 26, 2021 at 04:41 PM

    No it is not all good now, I still have records that are missing and I have no way of adding a process status to the missing records.


  • Profile Image
    Richard_Krouch
    Answered on February 26, 2021 at 05:15 PM

    I deleted the linked tables and deleted the columns, then I just added hidden fields on the forms for that information.


    So the take away for you guys is "linked tables is not reliable, does not work"


    I am okay now, no rush on a fix

  • Profile Image
    Richard_Krouch
    Answered on February 26, 2021 at 05:24 PM

    I also removed the sort on th linked field column and more records showed up.

  • Profile Image
    EltonCris
    Answered on February 26, 2021 at 06:43 PM

    Thanks for the update and I'm glad that the submissions data are now shown. If there are still missing data, please provide the submission IDs of these data so we can easily trace them. It would also help expedite our team's investigation. Thank you!

    Here's how to get the submission ID: https://www.jotform.com/help/549-Where-to-Find-the-Submission-ID

  • Profile Image
    Richard_Krouch
    Answered on March 02, 2021 at 01:05 PM

    Dude, If the submissions are missing I can't get to the submission ID

  • Profile Image
    EltonCris
    Answered on March 02, 2021 at 04:06 PM

    You're right, sorry about that. Anyway, I have already noted the two missing ones as you've mentioned like Sarra Johnson and Tina Doyle. If you're still unable to see them on your Tables until now then only our back-end team would be able to help. We'll keep you posted for updates.

    Thank you so much for your patience.

  • Profile Image
    Richard_Krouch
    Answered on March 02, 2021 at 06:16 PM

    Here is the problem solved of the missing records.

    If I sort on a column and there is a record without a value in that field the record does not display. Example in the process column in the image below.1614726844_603ec6bc74ea6_MissingProb1.JP

  • Profile Image
    EltonCris
    Answered on March 02, 2021 at 07:33 PM

    Thanks for the clarification. So the only problem now is with sorting which does not display blank submissions. I'll update the bug ticket according to your latest update.

    I could also see that the missing submission you mentioned e.g. Tina Doyle is now shown in your screenshot so they are now shown except that some go missing when the sort option is used.

  • Profile Image
    EltonCris
    Answered on March 02, 2021 at 08:02 PM

    By the way, I was also able to reproduce the sorting issue. When you sort the column with blank cells, those rows with blank cells will be hidden.

    03032021_JHhcxrCvcO.gif

  • Profile Image
    Richard_Krouch
    Answered on March 03, 2021 at 10:35 AM

    Good, I am glad you can reproduce the problem.

  • Profile Image
    EltonCris
    Answered on August 13, 2021 at 11:40 PM

    @Richard_Krouch

    Apologies for the late update. We'd like to inform you that this problem has already been resolved.

    Thanks!