Autoresponder not being updated with form field changes

  • Profile Image
    annieprice
    Asked on November 15, 2013 at 07:53 PM

    Hi there, my survey when the customers recive a copy of it has missing data but my version is complete.

  • Profile Image
    abajan
    Answered on November 15, 2013 at 09:18 PM

    Unfortunately, unlike notifications, autoresponders are not automatically updated with field changes. As such, each time such a change is made to the form, you will have to either create a new autoresponder or manually insert (or delete) the tags for the relevant fields. In this form's case, I think the first method would be better. Just copy the "Thank you very much for your application ..." message to your computer's clipboard before deleting the autoresponder, so that it can be pasted into the new autoresponder. That would be less hassle than having to type the message each time.

    If you need clarification on anything, please let us know.


    Thanks

    How to Delete Autoresponders

    Creating a Form Autoresponder

  • Profile Image
    abajan
    Answered on November 15, 2013 at 09:30 PM

    Actually, I should have stated that normally autoresponders are updated with field changes, just like notifications but that functionality isn't currently working. However, once the body of an email alert has been edited, the auto-update functionality will be disabled. This applies to notifications as well as autoresponders. This means that in your form's case, even if the auto-update feature was working correctly, the auto-responder would still need to be deleted and replaced (due to the "Thank you for ..." message it contains).

  • Profile Image
    steve
    Answered on September 16, 2014 at 09:04 PM

    Hello-

    I just confirmed this is working now. As per my colleague described:

    - if the autoresonder hasn't been edited before, then it will auto update as changes are made

    - if it has been edited by the user, then it no longer auto updates. Otherwise it might wipe out changes made by the user.

    Please let us know if you encounter further issues.

    Thanks!