What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Displaying twice While Embedded on Webpage

    Asked by samjatin on November 15, 2013 at 11:27 PM

    Hi there, first of all, great tool your are offering here. For someone who is totally new to the whole web-page page thingy it was very easy and intuitive to set up a form of my liking. 

     

    Now though I have some trouble. When I first "installed" the form everything was working fine. Then I had to change something on the template.css b/c I had some trouble with a gallery only showing 2 instead of 4 columns. 

    Since then I cant get the jotform to work. I tried using the source code instead of the joomla code. Nothing changed. I then used the search function here and most of the times it seemed that using the iframe code should do the trick. 

     

    Did that and now the form shows up 2 times, but still only the left halves. 

     

    Strange thing (well I guess for those experienced in css/html and what not it makes sense) is that the form appeared just fine when browsing with ipad/smartphone whilst being in half on the desktop.

    As of right now (using iframe code) it also appears double on the mobile. 

     

    I will leave the site online for now to let you see it for yourselfes. Hope someone can help. Pls keep in mind I am totally new to all this so be as plainly as possible. 

     

    I will now go to the bed since I have been on this for hrs... 

     

    Thanks in advance. 

     

    Site: http://bruetschi-hof.de/index.php/buchungsanfrage2

    Page URL:
    http://bruetschi-hof.de/index.php/buchungsanfrage2

    Screenshot
    JotForm iframe code source template
  • Profile Image

    Answered by samjatin on November 16, 2013 at 05:49 AM

    Nobody? 

  • Profile Image

    Answered by Cesar on November 16, 2013 at 08:43 AM

    Definitely it is a matter on checking the embedded code. I would suggest to completely remove any form code off the webpage and start over with new generated code from the Embed Form tool on the JotForm Form Editor.

    At this time I am unable to access the link you have provided as it directs me to a loging screen:

    https://cms.jotform.com/uploads/image_upload/image_upload/global/21067_loginscreentestform.png

    Do try the steps directed above and if that has already taken place, do let us know once access has been enabled back on to the site the form is currently embedded on.

     

    Related Articles:

    Getting-the-Form-iFrame-Code


  • Profile Image

    Answered by samjatin on November 16, 2013 at 09:00 AM

    Yes I took the page offline not long ago. 

     

    The strangest thing is, just talked to a friend and he said the form was perfectly fine on his side (notebook). So it works on iphone/ipad, my friends laptop and I noticed it works on my laptop as well...

     

    Just on my desktop pc its making trouble. I tried Chrome, IE10, FF  (IE10 & FF working) and cleared cache and everything. 

    Could it be a problem of the end-users display resolution? 

     

    Btw: While my friend was checking the form he encountered the following problem. When opening a drop-down selection it immediately closed. I did not have that problem. 

     

    Thanks for answering by the way. 

     

    Edit: Well its getting stranger by the minute. Just to make sure again I tried IE and FF again. Now it works. Just Chrome still making some trouble. The site is online if you want to take a look.

     

    Edit²: Just talked to my friend again. I asked him what browser he was using while having trouble with the drop-down boxes. He is using IE11 which just came out 5 days ago. Maybe thats the problem concerning that. 

     

    Edit³: lalala ok now its working even on Chrome. Maybe b/c I was logged in as Admin the form had some trouble on the frontend. The only thing I still need to check is if IE11 really messes up the drop-down boxes/selections/menu. 

  • Profile Image
    JotForm Support

    Answered by jonathan on November 16, 2013 at 11:40 AM

    Hi,

    By your latest message, do you confirm that all is good already?

    Kindly inform us if there is more we can assist you with.

    Thanks.

  • Profile Image

    Answered by samjatin on November 16, 2013 at 12:51 PM

    It is all working now. Guess it had to do with the site being in offline mode and me being logged in as the administrator in the frontend (the form ended where the editor button was appearing)

     

    Only one thing left to do. On the right/left side of the form the background is not visible transparent. Dont know if that is something I can change over here on jotform or have to do myself. 

     

    Edit: Cleared the backround color code. Transparent now. Everything working perfect. Again great tool. 

  • Profile Image
    JotForm Support

    Answered by Welvin on November 16, 2013 at 02:45 PM

    @samjatin,

    Great that you've figured out everything. If you have any questions, please don't hesitate to contact us again.

    Thanks for using Jotform.