Attachment and Signature not received with submission

  • Profile Image
    KarenBrody
    Asked on November 19, 2013 at 05:22 PM

      Hello! We have a JotForm set up to collect information and signatures from a speaker agreement. The form is embedded here: http://passionevolutionsummit.com/speaker-agreement-2/

      When the forms are submitted we are not getting a copy of the signature in the email. In addition, the files that people are attaching to the form are not being emailed to us or the speaker (we have an autoresponder so the speaker gets a copy as well).

      I've searched every setting and can't figure out what is wrong. Please help. We are in the middle of our submit and really need this to work.

    Thanks!

  • Profile Image
    EltonCris
    Answered on November 19, 2013 at 06:36 PM

    Hi there,

    The problem is related with script conflicts. When I checked your form here, the signature field doesn't appear on the initial load of the form. In order to fixed this, please re-embed your form using iframe embed code. How to get your iFrame Embed Code

    Regarding on the empty uploads, since they are not set as required, it is possible for the user to leave these fields empty. Make sure to set the field required if you want them to be filled in.

    Let us know here should you have further questions about this. Thank you!

  • Profile Image
    KarenBrody
    Answered on November 20, 2013 at 03:04 PM

    Thanks! I just changed it and ran a test - will follow up.

    One question re: using iFrame embed code - if I make changes on the JotForm side, do I need to copy the code and embed it on my site again? I usually use Javascript so I don't have to worry about this. I've never used iFrame so I'm not sure how it works.

    Also I can make the upload field required but I'm not sure that will solve the issue. I tested the form by attaching a doc and the doc was not sent to me. So it's not that somebody skipped the step, it's the doc was uploaded but not forwarded to us. Does that clarify?

    Thanks!

  • Profile Image
    EltonCris
    Answered on November 20, 2013 at 05:24 PM

    @KarenBrody 

    No, the form on framed embed should automatically update as well. There's no need for re-embedding the code. :)

    I have made an actual test with your form as per mentioned on your other thread. The screenshot shows the two uploaded documents as well.

    Here's another screenshot:

    Kindly check my advice on the other thread, that might help as well. Thank you!