What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Dropbox integration is busted, can't authenticate

    Asked by planetmike on November 24, 2013 at 08:34 AM

    I've tried to integrate Dropbox into a form. But it never authenticates. Tried in two browsers, flushed cache. Very frustrated right now. I actually set time aside today to get this setup and it won't work. Argh. Is this a Dropbox headache or a Jotform headache? On "My Apps" at Dropbox, it lists JotForm as having full acess. (Why do you need Full access? It'd be great if I could limit that to one folder and its sub-folders.) Thanks, Mike

    Page URL:
    http://www.jotform.com//?

    Screenshot
    dropbox JotForm cache integrate
  • Profile Image

    Answered by planetmike on November 24, 2013 at 08:37 AM

    I found this thread from last night, http://www.jotform.com/answers/291827-API-Dropbox-Authorization-Not-Working#8 . I'm using Safari 6.1 and Firefox 25.0.1 on OSX 10.8.

  • Profile Image
    JotForm Support

    Answered by EltonCris on November 24, 2013 at 08:49 AM

    Hi Mike,

    The Dropbox Integration works fine on my end and with my other colleagues. Are you following this guide? Upload to Dropbox with JotForm. We've completely moved the Dropbox App on the Integration section so just wanted to make sure you're on the right section. Please try it again by following the guide above and let us know if you still have problems.

    We'll await your reply. Thanks!

  • Profile Image

    Answered by planetmike on November 24, 2013 at 09:49 AM

    It's working now. but it wasn't working earlier. Honest. It was acting like something in the integration step wasn't caching or transferring correctly. Whatever. I'll let you know if it breaks again. My test submission went through just now. Mike

  • Profile Image

    Answered by Cesar on November 24, 2013 at 10:23 AM

    @Mike

    Thank you for your input. Do let us know if th eissue persists at some point, so that we may be able to provide you further assistance. Thank you.

  • Profile Image

    Answered by thedigitalyogi on March 12, 2014 at 04:11 AM

    I'm getting the same problem now :-(

    Click authenticate -> window appears with Dropbox Allow box (I'm already logged in to Dropbox) -> When I click allow the window closes and I'm back to the Jotform Authenticate window.

    I've logged out of Dropbox and re-tried. Same process but with the additional requirement to log into Dropbox before "Accepting".

    Weird thing is, that looking at my authenticated apps on Dropbox's website, Jotform is listed. I removed this access, tried the authentication process again, it failed in the same way as above, but Jotform was re-added to my alls list on Dropbox's website.

    So it looks like it's working, but not passing the correct info back to the Jotform integrations software. Hope that helps in fixing the problem.

    Any suggestions?

    Regards,

    James

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 12, 2014 at 07:18 AM

    Hello James,

    I'm sorry for the trouble caused to you.

    I just tried to integrate one of my form with dropbox and I was able to do that successfully. I would suggest you to clear your browser cache once and then try to integrate your form again with your dropbox account. That should most likely solve your problem.

    Do get back to us if the issue persist. You should create your own thread.

    Thank you!

  • Profile Image

    Answered by wolfpaw69 on December 30, 2015 at 02:03 PM

    I have the same problem. You can see from the print screens below.  

    1. Select integrations

    2. Select Dropbox

    3. Allow

    4. Authentication Failed!

    This is done on Chrome.  First time I'm trying to integrate to dropbox.

  • Profile Image

    Answered by wolfpaw69 on December 30, 2015 at 02:52 PM

    I tried it again about an hour later and now it works.

  • Profile Image
    JotForm Support

    Answered by Kevin_G on December 30, 2015 at 06:16 PM

    Hi  wolfpaw69 ,

    We are glad to know the integration is working for you now.

    Please, do not hesitate to open a new thread if you need further assistance.

    Regards.