Zoho Integration Not Working

  • Profile Image
    yuan.z
    Asked on March 08, 2021 at 09:16 PM

    Hi. Thank you for connecting. I started using Jotform today according to my friend's recommendation. My goal is let responses go into Zoho CRM - Lead Module. I setup the integration and it worked for the first submission. But after that all others submissions failed. They didn't appear in Zoho as expected. Could you help me check what is going on?

  • Profile Image
    Ahmed_S
    Answered on March 09, 2021 at 12:25 AM

    Hello Yuan,

    Thank you for choosing Jotform to aid you with your business.

    I've checked your form and you may need to set the option of Trigger your workflows in Zoho CRM to Yes in your current Zoho CRM integration, please check this guide for more details:

    How to Integrate Jotform with Zoho CRM

    1615267410_60470652362dc_2.png

    Please let us know if you need further assistance, we will be glad to help you any time.

  • Profile Image
    yuan.z
    Answered on March 09, 2021 at 12:51 AM

    Hi Ahmed_S,

    Thank you for helping answering my question. I did as you said to set the trigger to yes, and it worked for one record and again stoped working. I tested 4 times only 1 time the record is successfully ported into Zoho CRM. Can you help me check what is wrong?

  • Profile Image
    Rehan_F
    Answered on March 09, 2021 at 03:17 AM

    Greetings,

    I've tested Zoho CRM integration in a clone of your form using exact same settings as yours and I'm able to receive the leads in the Zoho CRM.

    1615277730_60472ea245a09_

    If it is still not working on your end then kindly delete the current integration and reintegrate using a new browser.

    If the issue persists then please let us know here.

    Thanks

  • Profile Image
    yuan.z
    Answered on March 11, 2021 at 05:16 PM

    Hi Rehan_F,

    Thank you for your help. I did as you said - to delete the integration and recreate it in another browser. And it worked for one time and stop working again. It's always like this - when I delete and recreate the integration it worked for one lead, but after that no matter how many times I submit the form the rest leads won't go into Zoho CRM. Can you test on your end to submit multiple times? To see if it work on your end? Or is there any limitation for multiple submission from one browser in a short time? I just couldn't figure out why. So weird. I really look forward to using Jotform but I couldn't share it with my sales guys knowing it will break after first time use. Thank you for your time!

  • Profile Image
    gerardw
    Answered on March 12, 2021 at 12:04 AM

    I am able to replicate this at my end. I tried multiple submissions on a cloned version of your form and mapped only the basic name and email fields. Only one submission passed onto Zoho.

    Let me check, test further and revert.

  • Profile Image
    gerardw
    Answered on March 13, 2021 at 04:55 AM

    I am escalating this to our back-end team. Once there is an update we will let you know via this ticket.

  • Profile Image
    onurince
    Answered on March 29, 2021 at 11:08 AM

    We apologize for the inconvenience.

    I've checked the integration logs. There was the following error from Zoho:

    -Required field not found: Company

    It seems that your Company field is a required field on Zoho. However, it is not required on your form and the form can be submitted with a blank value. For this reason, integration is not working properly.

    Can you please try to send some test submissions by filling the Company field?

    Please let us know how it goes.

    Thank you.