Notification Emails missing PDF attachments

  • Profile Image
    collingabriel
    Asked on March 10, 2021 at 08:31 AM

    Hello, some of the Notification Email's being sent from our form are not being sent with attachments. The issue has been happening for a few weeks not but seams to be getting worse the past few days. All of the notification emails are being sent with the correct information in the body of the email, but the attached PDF that should accompany the email is not showing up on all of them. It started with one or 2 a week sending without the PDF, but this week it seems like about 50% of the notification emails are not containing the attachment.

  • Profile Image
    Cecile_A
    Answered on March 10, 2021 at 09:20 AM

    Hi,

    Thank you for contacting support.

    We got an update from our developers that the issue has already been fixed. Kindly check on your end if the PDF copy of the submission is now being attached to the email alert sent when your form is submitted. Otherwise, please do not hesitate to contact us again anytime and we will be glad to help you.

  • Profile Image
    VDRESG
    Answered on March 10, 2021 at 09:25 AM

    I have the same issue this week even if I download all the attached PDf files from the submissions panel control. 80% of my PDF files are corrupted. I'm on a Apple computer. Thanks for your help


  • Profile Image
    Cecile_A
    Answered on March 10, 2021 at 10:36 AM

    Does this issue happen to particular forms? If so, could you please send us the name or URL of the forms so that we could check it on our end?

    Guide: https://www.jotform.com/help/401-where-to-find-my-form-url

    If you could send us a screenshot of the error you are encountering, it would be greatly appreciated.

    Guide: https://www.jotform.com/help/438-how-to-post-screenshots-to-our-support-forum

    Looking forward to your reply.


  • Profile Image
    VDRESG
    Answered on March 10, 2021 at 01:43 PM

    Yes it is. Here are the links:

    https://www.jotform.com/inbox/203486304298258 (one of the PDF Files in 3/4 forms can't be opened)

    https://www.jotform.com/inbox/203235856857263 (same issue here almost one PDF in every form can't be opened)

    When I download the file, I try to open it with Acrobat reader or Preview and I get a message of the file is damaged and can't be repared. Here is the screenshot (It is in french). Thanks for your help.

    1615401656_604912b837446_Capture d’é


  • Profile Image
    Cecile_A
    Answered on March 10, 2021 at 04:24 PM

    Thank you for the update.

    I have cleared your form cache. Kindly clear your browser's cache as well and try downloading the submissions again.You could also try using a different device when downloading and see if there are any differences.

    If the issue still persists, kindly let us know.

  • Profile Image
    VDRESG
    Answered on March 11, 2021 at 03:36 PM

    Thanks, that took care of the issue where I was not able to download some files directly from the inbox view.

    That leaves me with the other issue that arises when I try to download all attachments from the "Tables" section. This usually generates a .zip file, sends me an email with the link to the generated zipped file, and then I can download the file, unzip it in a local folder, then read the attachments (generally in pdf form).

    What currently happens is that I click on the "Download all documents", the pop up telling me that the system will send me a link appears, I click "I understand", then I receive a link to the file. Up until then, it all goes according to plan. What's wrong is that the zipped file can be unzipped just fine, but some/most files inside the archive appear to be truncated. Directory structure is OK, but the pdf files are incomplete, and the sizes are rather small (goes as low as 7kb). Looking at the file using an HEX editor shows no %%EOF at all at the end of the pdf file.

    I have tried downloading the zipped file using more than one system, and more than one operating system/browser combination and the same thing happens (my main system runs osX Catalina, also tried from Windows 10 using Chrome as well as edge, and Ubuntu using Chrome and Firefox). I tried opening the .zip file using the regular osX inflator, and on Windows tried both 7zip, Winzip and the vanilla windows broker. On linux/Ubuntu, I only tried Ark. With all these programs, I achieved the same result, which tells me that there might be something astray with Jotform's attachment handling during compression.

    I'm open to any suggestions. I would really like the "download all attachment" feature to be back up and running for my purposes as this saves me tons of time.

    Best regards,

  • Profile Image
    Cecile_A
    Answered on March 11, 2021 at 04:50 PM

    We're glad to know that the first issue was resolved.

    With regards to your other concern, I have moved it to a new ticket to avoid confusion with this thread.

    I'll be addressing your new concern here shortly: https://www.jotform.com/answers/2960957

    Thank you.