Email PDF attachments going haywire.

  • Profile Image
    Eamonn_marketing
    Asked on March 10, 2021 at 10:40 PM

    Hi folks,


    Experiencing a lot of difficulty and frustration with PDF attachments to emails.


    I want to attach an invoice with {productlist} and other order details to both the emails that get sent to {yourEmail} and to our business.

    The problem is that sometimes no PDF is attached, and sometimes the wrong PDF (automatically generated 'Simple Invoice') is attached rather than the custom invoice I've designed. Additionally, jotform has generated 150+ 'simple invoices' in the PDF Editor view, and I can't see any option to get rid of them but deleting them one by one. On some occasions emails will come through with 150+ PDF attachments. It seems that the saved setting of what PDF to attach keeps being reset or changed, through what mechanism I do not know. Sending test emails under the email tab seems to break everything so I've been testing by just filling out the form at its hosted URL and seeing what emails/PDFs get spit out.

    In the past I had the 'generate an invoice' option enabled in the Product List module, and at the same time I had a custom invoice PDF email attachment marked to send alongside the autoreply emails. I think was causing some of the issues (I read this in another forum post). I've now disabled the 'generate an invoice' option under Product List but the emails seem to be a little spotty still, and unreliable in terms of what they attach.

    There's obviously something buggy going on with the emails, I'm wondering if it's possible to clone just the content of a form over to a new workspace (and none of the email accoutrements) and then set up the email stuff again from scratch? I don't really feel like deleting 160+ 'Simple Invoices' haha.

    I've attempted to clone the form but that did not resolve the issue. I've also deleted the email templates and created new ones, but issues still persist.

    Please advise.

    Thanks

  • Profile Image
    Rehan_F
    Answered on March 11, 2021 at 05:45 AM

    Greetings and apologies for the inconvenience.

    We had this issue reported to our backend team already and they were working on fixing it. I've checked your PDF editor and currently, I see only one PDF document.

    1615459400_6049f448a7dbf_

    Sorry if you had to delete all the auto-generated invoices in the editor. The issue is fixed now and the auto-generated invoices should not appear again. Just in case if they do then please let us know here so we can escalate the issue again.

    Thanks