What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Required field validation is not working on my form (with calculations)

    Asked by CecilevdM on December 03, 2013 at 04:16 PM

    Hi. When I try to submit my form without having entered all the required fields it doesn't give the error messages anymore that you cannot submit without having completed the required fields. Instead the form just submits. How can I fix this?

    Thanks!

    Page URL:
    http://form.jotform.co/form/33224317129852?

    thanks required validation
  • Profile Image
    JotForm Support

    Answered by EltonCris on December 03, 2013 at 11:08 PM

    Hi there,

    For some weird reason, I was able to reproduce the problem on your form but not on the new forms created. The problem seems to be form specific which I have no clue as of yet. I will keep on investigating your form so I could find out what causes your form validation to break down.

    We'll keep you updated. Sorry for any inconveniences caused.

  • Profile Image
    JotForm Support

    Answered by EltonCris on December 04, 2013 at 04:02 PM

    @CecilevdM

    Sorry for taking time on this and for the delay. The problem is now escalated to our developers for a quick fixed.

    Thanks and apologies.

  • Profile Image

    Answered by ricardogonzales on December 13, 2013 at 10:23 AM

    Hi, I've got the same problem. I tried several times without any results. Pls help me. 

    Thanks in advance.

     

    Page URL:

    http://form.jotformeu.com/form/33463587721359?

  • Profile Image

    Answered by heathersl on December 13, 2013 at 10:59 AM

    Happening over here, too! My form is located at http://form.jotform.ca/form/33296311496256

  • Profile Image

    Answered by pinoytech on December 13, 2013 at 12:55 PM

    @ricardo

    Unfortunately, I wasn't able to reproduce the issue upon checking your form. Please take a look at this video: http://screencast.com/t/zMvMHfTqP

    Have you tried already clearing your browser cache and cookies as well as form cache? If not, can you please give a try?

    If the said issue still persists, please do let us know.

  • Profile Image

    Answered by ricardogonzales on December 13, 2013 at 02:38 PM

    Hello Pinoytech,

    first of all thanks for yr prompt reply. Unfortunately I just tried what you suggest but it still doesn't work, the issue persists. I've checked in yr forum and I did't find any other solution. Pls tell me how I can fix such problem.

    Thanks

  • Profile Image
    JotForm Support

    Answered by Mike_T on December 13, 2013 at 04:16 PM

    The required validation is not working right due to conflicts with calculations script on form. Elton has already forwarded a ticket about this, so we will need to wait for a fix from our Development Team.

    We will update this as soon as we get any news.

  • Profile Image

    Answered by CecilevdM on December 18, 2013 at 11:10 AM

    Hi. After I couldn't find a fix for this, I deleted the form and redid it. Everything was working fine for about 10 days and students could submit the form. We didn't change anything on the form and about 2 days ago it started giving issues again. Again it is possible to submit without filling in all the required fields. But when you try to submit, nothing happens. The submit button says "Please wait" but doesn't matter how long you wait nothing happens. Please help with this! Registration for students has opened and now no one can register.

     

    http://form.jotform.co/form/33371174968867?

  • Profile Image
    JotForm Support

    Answered by Mike_T on December 18, 2013 at 02:50 PM

    @CecilevdM,

    That issue is most probably different from the ticket that was attached to this thread.

    I was able to submit a cloned version of your form. If the issue still persists, please report it on a separate thread. We will do our best to help.

  • Profile Image

    Answered by ricardogonzales on December 19, 2013 at 04:20 AM

    Hi. I've got the same problem than before. I cloned the previous form (http://form.jotformeu.com/form/33463587721359?) I changed some fields and the new one (http://jotformeu.com/form/33495008668362) was working very well until today. Like CecilevdM it's possible to submit without filling some required fields. What can I do? Pls help me. Thanks

  • Profile Image
    JotForm Support

    Answered by jonathan on December 19, 2013 at 07:54 AM

    @ ricardogonzales

    The original poster's issue had been submitted as bug and was assigned a ticket already.

    I suggest that you please create a new separate thread for your concern so that we can dedicate support for it separately.

    Use this link to create new thread http://www.jotform.com/contact/

    You can copy and paste your message on this thread and just add the appropriate title/subject for it.

    We will attend to your post as soon as we can.

    Thanks.

  • Profile Image

    Answered by remiel on March 14, 2014 at 10:24 AM

    I am having the same problem. What is the status of this bug?

  • Profile Image

    Answered by EliezerN on March 14, 2014 at 01:15 PM

    @remiel

    As you probably already read in the previous messages of this thread, this issue has been forwarded to our next level support. They are still working on the bug and have not updated us yet. 

    So, in order to give you assistance to your particular issue, kindly open your own thread. That will allow us to give follow up to your case. You can open a new thread here: http://www.jotform.com/answers/answer.php

    This thread will updated also once the issue is resolved.

    Thanks