Upload of files larger than 100mb doesn't work

  • andystan
    Answered on December 21, 2013 04:14 PM

    Please Help


    Whenever I'm trying to upload a file larger than 100mb, the upload crashes after around 7%


  • Jeanette JotForm Support
    Answered on December 21, 2013 09:49 PM

    That is because you have not set the size in multiples of 1024 kb

    So for example, for 1GB you must do 1024*1000 = 1024000

    Upload of files larger than 100mb doesnt work Image 1 Screenshot 20

  • andystan
    Answered on December 22, 2013 11:28 AM

    Thanks Jeanette,

    I entered 1024000 in the Max File Size field ... and it is still not working. Can you try to upload a large (200mb) file to my form to see it will work for you? http://form.jotform.co/form/33544329565864 

    Also, can you try to create a form with a file submit option and send me a link to try? 

  • Jonathan JotForm Support
    Answered on December 22, 2013 04:29 PM



    Can you please try uploading to my test form here https://secure.jotformpro.com/form/33555943131958?  it has maximum file upload size of 200MB.

    I will also test on your form http://form.jotform.co/form/33544329565864  though it would take a while for me to give you result, but I will do update you on it.

    Please inform me also of the results on your test on the test form.


  • andystan
    Answered on December 22, 2013 05:00 PM

    Hi Jonathan,


    I was able to upload to your form no problem. 

    It seems there is a difference between the forms when they are using the jotformpro.com versus jotform.co domains...  


    I tried another form from another user that also was using the jotformpro.com domain and that one worked fine as well. 

    Here is my form once again: http://form.jotform.co/form/33544329565864 


  • Jonathan JotForm Support
    Answered on December 22, 2013 05:42 PM


    I am able to reproduce thei issue on your test form the moment I tested it.

    To further test, may I suggest you do the ff: procedures.

    1. Clone my test form http://www.jotformpro.com/form/33555943131958  (use this guide: -How-to-clone-an-existing-form-from-a-URL)

    2. Save the form to your account.

    3. Test/Preview the form (you can try uploading the same tesf file you have uploaded in my test form)

    From previous experienced, I do learned that the single file upload field is unstabe when the set max file size is greater than 250MB -- for your case, I assume that the issue have to do with the file size being set to 1GB at once.

    For such cases, it is usually suggested to break down the single upload of 1GB into multiple single upload fields. That is, put several upload field(single mode) in the form that equals to 1GB total size when form is submitted.


  • andystan
    Answered on December 22, 2013 06:15 PM

    Hi Jonathan, 

    Thank you!!! We have good progress!

    When I cloned your form the upload worked ok... The URL for this cloned form 


    Note that it is jotformpro this time ... I still think this may have something to do with it. 

    After testing it with a 130mb file (which worked fine), I modified the form to accept 1024000kb files and tested with a 400mb file and that worked as well.... I suspect that even larger files would work as well. 

    Am I able to get my account modified such that all forms that I create will be using the "jotformpro" domain?  

  • Jonathan JotForm Support
    Answered on December 22, 2013 09:01 PM

    Sorry for the delayed response.


    Since you are now a paid subscriber, the new forms you create should also use the jotformpro.com domain. If this is not happening, you can also try using the URL when logging in to your account http://jotformpro.com/

    Please inform us if issues still persist.


  • andystan
    Answered on December 22, 2013 09:11 PM


    I agree with you. I think this is what the problem seems to be. I just tried to create a new form and still, the domain is not the jotformpro.com

    How do I fix this? 

  • NeilVicente
    Answered on December 23, 2013 05:29 AM


    Try to log out your account then log back in. If that doesn't work, clear your browser's cache

    and restart it thereafter. Please let us know how it goes.