Sign in to approve Jotform

  • Profile Image
    dougstack
    Asked on May 06, 2021 at 12:32 PM

    I have set up an approval flow and although I have unticked the require login to jotform when the person clicks on the email to approve or deny they are taken to a page where they have to log in and can't proceed any further without.

    Screenshot
  • Profile Image
    JohnRex
    Answered on May 06, 2021 at 06:49 PM

    I have tested this feature on my end and it seems to work as intended.

    Based on the screenshot, the URL is incomplete. It should be like this:

    1620341167_609471af732f6_

    Please advise them to ensure they are accessing the said page by clicking on the Approve/Deny buttons in their received email.

  • Profile Image
    dougstack
    Answered on January 05, 2022 at 05:37 AM

    I have double checked and they were clicking on the approve button, we then tried copying the link and received the same issue. We have managed to access the approval page without logging in by using a different browser, any suggestion as to what could be causing this?

  • Profile Image
    Jovanne_A
    Answered on January 05, 2022 at 06:16 AM

    Hi,

    There seem to be several forms under your account. Could you please provide us with the form URL in question so we can check?

    Could you also please try clearing your browser cache and check if that can help?

    We look forward to your response.

  • Profile Image
    dougstack
    Answered on January 07, 2022 at 12:00 PM

    Form URL: https://form.jotform.com/211323065513342

    We have also noticed that on this form that when the approver receives the approval email any data entered into the tables of the form is missing from the email ( it can be viewed when you go to the approval screen)

  • Profile Image
    Katherine_W
    Answered on January 07, 2022 at 01:22 PM

    Hi there,

    Thank you for confirming the form URL with us!

    Please allow me a little time to clone, test, and further investigate and I will get back to you as soon as possible via this thread.

    I thank you in advance for your patience and understanding as I look into this for you!

  • Profile Image
    Katherine_W
    Answered on January 07, 2022 at 04:42 PM

    Hi again,

    Thank you for your patience as I tested and investigated this issue further.

    I created a clone of your form https://form.jotform.com/211323065513342 and sent through several test submissions and I was unable to replicate the issue where I was asked to log-in even without being logged into Jotform whatsoever nor the issue with the approval emails you had mentioned.

    I tried a VPN as well to see if this issue was perhaps location-dependent, but it does not seem that way. As I see that you are in the UK, please allow me some time to confer with my European colleagues to see if they can replicate the issue as well.

    Your continued patience and understanding is most appreciated!

  • Profile Image
    Lars_L
    Answered on January 08, 2022 at 10:10 AM

    Hello,

    I've done some testing as well, but have also been unable to replicate the issue. The links in the Approver emails go straight to the Approval and Signing, without asking for any login.

    Would you be able to copy the link address from one of the emails the approvers have received? So we can see if the issue is present already there. Perhaps the generated links are missing something.

    1641654151_61d9a7875185d_

    I did find the reason for the timesheet not showing in the emails. The emails currently use {dailyTimesheet} to show it, but the field is currently called "dailyTimesheet12". The easiest way to fix this is to change the Unique Name on the field, then all the email with the {dailyTimesheet}-tag will show it correctly again.

    1641653791_61d9a61fae268_

    This setting is found in the properties for the field, under the Advanced tab, in the Field Details section.

    Best regards,
    Lars

  • Profile Image
    dougstack
    Answered on January 10, 2022 at 04:16 AM

    As i previously mentioned the link in the email appears to be correct, as when the email was forwarded to another member of staff they could click the link successfully, equally when we copied the link and opened in a browser that wasn't the default it took them to the right page. Therefore i am not sure what is causing it to use the one in the original screenshot sent.

  • Profile Image
    Jovanne_A
    Answered on January 10, 2022 at 06:15 AM

    Hi,

    Could you please try clearing your browser cache and see if that can help?

    I have also cleared your form cache on our end as a precaution.

    Please give it a try and let us know how it goes.