What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why are iframe embeds working when I insert them and preview the form but disappearing after I logout and back in and edit the fomr?

    Asked by JMorse on December 24, 2013 at 02:53 PM

    I am trying to embed this form   :

    http://form.jotform.co/form/33575378162865

    as an iframe into a Free Text field on this form:

    http://form.jotformpro.com/form/33572199919974


    logout preview disappearing and
  • Profile Image
    JotForm Support

    Answered by Mike_T on December 24, 2013 at 03:03 PM

    I think that this is happening due to our recent security updates. We have added some fixes to prevent any possible XSS attacks.

    I have submitted a ticket about that issue with stripped iFrames. We will get back to you via this thread when we have any news.

  • Profile Image

    Answered by JMorse on December 24, 2013 at 03:05 PM

    Thanks...it was driving me nuts. Standing by.

  • Profile Image
    JotForm Support

    Answered by kenneth on December 29, 2013 at 12:54 AM

    Hi we made a patch to fix this issue. In any case let us know if this reach your forms.
    And if not please report back in order to further investigate the problem.

    Thank you for patience and cooperation.
    -Kenneth 

  • Profile Image

    Answered by JMorse on December 29, 2013 at 02:27 PM

    So far, so good. This seems to have been rectified. Kudos to your Support Staff. You all rock!

  • Profile Image
    JotForm Support

    Answered by jonathan on December 29, 2013 at 02:38 PM

    Thank you for taking the time to update us.

    Our developer have received your latest message.

    Best Regards,

  • Profile Image

    Answered by JMorse on December 30, 2013 at 04:55 PM

    Hmm...might there still be a bug? I am embedding this form:

    1. http://form.jotform.co/form/33575378162865

    into this form as an iframe in a FreeText field:

    2. http://form.jotformpro.com/form/33572199919974

    Form 1 works perfectly all the time on its own, however when embedded in Form 2, it works fine at first but when I try it later, the right side of the form is cut off. I increased the form width to 160% in the iframe...still not workng right.


  • Profile Image
    JotForm Support

    Answered by KadeJM on December 30, 2013 at 07:12 PM

    We appreciate you explaining this issue more to me. I've tested this myself via two cloned forms of your form 1 and form 2 to check it. Perhaps what you see below is what you might be seeing which may be misleading to cause some confusion with the problem at hand.

    Was there a browser that you were viewing it in and it was still cut off? If so then which one and what version of the browser were you using?

    Its notable that inside of the form when it's embedded it certainly appears cut off inside that field.

     

    However, when viewed on the form itself as a whole it can be seen that this is clearly not the case.

  • Profile Image

    Answered by JMorse on December 30, 2013 at 08:37 PM

    The right side is cut off in both the most current version of Chrome and with  IE 11. Behaves the same in both browsers.

  • Profile Image
    JotForm Support

    Answered by EltonCris on December 30, 2013 at 11:54 PM

    @JMorse 

    The embedded form as iframe doesn't have a width property on the style attribute that's why it gets cut off on the right side. Please re-embed your form with the following.

    <iframe scrolling="no" frameborder="0" src="//form.jotform.co/form/33575378162865" style="height:480px;width:710px;border:none;"></iframe>

    I have bolded the corrected part of the code. This might fixed it. Thanks!

  • Profile Image

    Answered by JMorse on December 31, 2013 at 08:26 AM

    The iframe code generated for the embedded form produces height and width properties in the code as: style="width:100%; height:480px; I don't know much about html and css but I am guessing that using the % value, ratheer than apx value is the problem. I copied/pasted the generated iframe code exactly several times and experienced the same problem repeatedly and, as you noted when you viewed the iframe code, the width value was missing altogether. I didn't remove it. It was getting stripped at some point in the process. Using your suggestion will hopefully now make it stick. So far so good. Thanks for your help. If it fails again, I'll be in touch!

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on December 31, 2013 at 12:17 PM

    We are very happy hearing your issue was sorted out.

    Cheers!