Approval workflow: no option to approve/deny in the inbox and the submission will stay in progress

  • Profile Image
    MatthewCottam
    Asked on May 20, 2021 at 06:26 AM

    I have created a approval process for a new employee form.

    The employee and their manager fill in the form, and an approval email is sent to the head of department.

    The head of department uses an edit link to the form contained in the email to enter in the employee's pay rate. They then click on the Approve button in the email.

    When they do this the approval is not being processed, and the form continues to be displayed as awaiting approval by the head of department.

    What changes do I need to make to ensure that the head of department can successfully authorise the form?

    Regards

    Matthew

  • Profile Image
    Lorenz_A
    Answered on May 20, 2021 at 07:39 AM

    Greetings,

    I've checked your form's approval setting and I don't see anything wrong on how it is currently configured, however, you have 1 error on your approval builder which could be causing the issue.

    1621510648_60a649f8d80aa_Approval- New S

    Kindly please remove that particular email outcome and see if that'll make any difference.

    I hope this helps. If the issue still persists, please let us know.

  • Profile Image
    MatthewCottam
    Answered on May 20, 2021 at 10:35 AM

    I have deleted the email outcome as you have suggested, but the problem still remains.

    Is the problem being caused by the head of department editing the form using an edit link?


  • Profile Image
    JohnRex
    Answered on May 20, 2021 at 12:29 PM

    Hello Matthew - I believe I already addressed the said issue on your other ticket: https://www.jotform.com/answers/3084902.

    Editing the submission using the regular edit link won't trigger the workflow as it was not part of the active process.

    So instead of sending the edit link via the regular email notification template, please use the REQUEST MORE INFO option in the Approval Workflow. Here's how:

    Enable the option in the Approval properties shown below:

    1621527978_60a68daa46ee0_

    Then when the HOD received the email, let him select request additional information:

    1621528120_60a68e38d5f87_

    And that's it! After editing the submission, that he can then proceed with Approving the application.


  • Profile Image
    MatthewCottam
    Answered on May 24, 2021 at 04:54 AM

    Hi,

    I have now changed the approval process for this form, and removed the edit link from the email, to resolve the problem detailed above.

    The approval process is now more straightforward but is is still not working.

    The employee & their manager complete the form, and it is sent to the head of department for them to enter a wage rate in the comments box and be authorised.

    This step is not working.

    The head of department is receiving an email with Approve or Deny buttons on. When they click Approve they are taken to their Jotform inbox where they can see 4 emplyees who are shown as Pending Approvals, however there are no buttons shown for them to Approve the submissions.

  • Profile Image
    Lorenz_A
    Answered on May 24, 2021 at 07:35 AM

    Hi there,

    The head of department is receiving an email with Approve or Deny buttons on. When they click Approve they are taken to their Jotform inbox where they can see 4 emplyees who are shown as Pending Approvals, however there are no buttons shown for them to Approve the submissions.

    Just tested with one of my form and the approval tool is working as expected, the approval/deny buttons are showing when redirected to the inbox.

    1621856125_60ab8f7da01e0_JotForm Inbox 2

    Also, you are referring to the first approver in the flow, right? Was the email on that approval section logged in with Jotform when he opens the Jotform inbox through the approval email? If so, could you please try enabling the "Require login for approver" and see if that'll make any difference.

    1621856055_60ab8f379ecc8_Approval- New S

    Please give it a try and let us know how it goes.

  • Profile Image
    MatthewCottam
    Answered on May 24, 2021 at 12:05 PM

    Hi, Yes I am referring to the first approver in the flow. They were logged in to their Jotform account when they clicked the approve button. When they viewed the form in their Jotform inbox the 'Attention Required' title and the Approve & Deny buttons were absent from the form:

    1621872199_60abce47ec805_

    I tried adding a tick to the 'Require login for approver' box and then generated a new submission to test, and the problem remained.

    Regards

    Matthew


  • Profile Image
    Richie_P
    Answered on May 24, 2021 at 01:52 PM

    To clarify, after clicking on approve/deny in the email, the users are not able to select these options in the inbox?

    firefox_t6kckVyG98.png

    May we know if the submissions are still showing in progress in the inbox?

    Looking forward for your response.

  • Profile Image
    MatthewCottam
    Answered on May 25, 2021 at 04:20 AM

    Hi, Yes, after clicking the approve button in the email the user is taken to the inbox. The form in the inbox does not have an approve or deny button on it for the user to click.

    The submission is still showing as in progress in the user's Jotform inbox.

    When I go to my inbox it's status says 'In Progress' and the form has a heading on it saying 'Waiting for Karen Wain's approval'.

    Karen Wain is the user who is unable to authorise the form.

  • Profile Image
    Richie_P
    Answered on May 25, 2021 at 05:55 AM

    Thank you for explaining further the issue.

    I have escalated the issue to our back-end team for further investigation.

    Once we have updates, you will be notified.


  • Profile Image
    ezgi
    Answered on May 28, 2021 at 02:03 AM

    I cloned your form and approval flow to see whether the issue is a reason of a temporary error on our end and it seems that the issue that you are having is not related to that temporary error.

    Our team is started working on the issue to find the cause and fix it. When we have an update on it, you will be notified.

  • Profile Image
    mayashope
    Answered on June 18, 2021 at 10:25 PM

    Any update on this issue? I believe we were having the same problem.

  • Profile Image
    Lorenz_A
    Answered on June 18, 2021 at 11:47 PM

    Hi there,

    We haven't received any update yet from the assigned team, however, the ticket is currently open and marked as "important" so rest assured that they are working on a solution for this.

    I have sent them a follow-up message as well to see if we can get any progress from them.

    We'll keep you posted via this ticket.

    Thank you.

  • Profile Image
    Anita McGonigle 
    Answered on July 06, 2021 at 08:10 PM

    Keen to have an answer to this also, as we have many 'in progress' tasks which need to be approved.

    Thanks Support Team.

  • Profile Image
    Lorenz_A
    Answered on July 06, 2021 at 09:25 PM

    Hello Anita,

    I have moved your query on a separate ticket to avoid confusion and for us to assist you better.

    We'll be responding to your query here https://www.jotform.com/answers/3204827.

    Thank you.

  • Profile Image
    Lorenz_A
    Answered on July 07, 2021 at 10:37 AM

    Hello @MatthewCottam,

    We recently had an update from our dev team, and they found out that the problem was with the upper letter in the email addresses.

    Kindly please double check.

  • Profile Image
    MatthewCottam
    Answered on July 13, 2021 at 09:21 AM

    I have changed the email addresses in the approval flow to remove the capital letters. This has resolved the problem.

    Thank You