[Android Devices] Field Input Mask breaks mobile functionality

  • Profile Image
    sbohler
    Asked on January 01, 2014 at 05:22 PM

    Greetings,

    I created a very simple form for a website project which includes a Phone Number field.  When I apply an imput mask of ###-###-### the field will not accept input from my mobile phone (Andriod - Samsung Galaxy S3).  Removing the input mask fixes it, but then I lose the mask.

    My form:  http://jotformpro.com/form/33636619553966 (*** in production - do not alter).

    Please advise.  I will adjust my form after I know the solution.

    Thanks and Happy New Year,
    Scott

     

  • Profile Image
    EltonCris
    Answered on January 01, 2014 at 06:32 PM

    Hi Scott,

    I couldn't reproduced the problem on my test at browserstack. The input mask works just fine with your other field. Phone field doesn't seem to have a mask as of this writing.

    The first line accepts letter, and the rest are numbers. When you intend to press letters on the number part, it simply won't be captured on the box.

    May we also know what browser you are using? Can you please try it with Chrome or Firefox for Android? On my test, I used the Android default browser.

    Please update us with the result. Thanks!

  • Profile Image
    sbohler
    Answered on January 02, 2014 at 12:32 PM

    I used Chrome on my Android phone.

    The mask on the Phone Number field has been removed because it prevents input via phone.

    Please duplicate this form to create a test form, set it's Phone Number field mask to ###-###-#### and give it a try with Chrome.

    My Key Code mask is working just fine.

    Thanks,
    Scott

  • Profile Image
    EltonCris
    Answered on January 02, 2014 at 01:35 PM

    @Scott

    May I suggest you to use the Phone Number tool under Quick Tools then enable Input Mask. This seems to work fine. 

    Example:

    Result:

    Cloned form: http://form.jotformpro.com/form/40015750891956?

    Hope this helps. Thanks!

  • Profile Image
    sbohler
    Answered on January 02, 2014 at 04:20 PM

    Thank you, but no joy.  This accepts input on Android+Chrome but the mask doesn't work.  It allows me to enter 5555555555555 into the first character of the (___) part of the field.

  • Profile Image
    Mike_T
    Answered on January 02, 2014 at 04:48 PM

    The issue is not happening on iOS devices and desktop browsers, so it seems to be related to the Android devices/browsers only. We were able to reproduce it, so we have escalated a bug report ticket to our Development Team.

    We can not provide any ETA, but we will update this thread once we have any news.

  • Profile Image
    sbohler
    Answered on January 02, 2014 at 04:50 PM

    Excellent.  Thank you.

  • Profile Image
    kenneth
    Answered on January 06, 2014 at 10:30 PM

    Hi, just want to tell you that this issue is now fixed. Please confirm if it works from your end.
    Report back if you faced any more problems.

    Thanks,
    Kenneth